Есептің қойылуы


Дипломдық жобаның техникалық тапсырмасында қызметке орналасуға арналған ақпараттық-анықтамалық қарапайым жүйе құру талап етіледі. Құрылған жүйе жұмыс берушілер мен жұмысқа орналасқысы келетіндер жайында тізімді сақтауы тиіс. Әрбір жұмыс берушіде бірнеше вакансия болуы мүмкін. Әрбір ізденушіде (қызметке орналасқысы келетін адамда) бірнеше резюме болуы мүмкін. Сонымен қатар, жүйе қызмет берушілерге қызметкерлерді таңдауға, ал ізденушілерге жұмыс орнын табуға көмектесуі тиіс.

Пән: Информатика
Жұмыс түрі: Материал
Көлемі: 4 бет
Бұл жұмыстың бағасы: 300 теңге




Есептің қойылуы

Дипломдық жобаның техникалық тапсырмасында қызметке орналасуға
арналған ақпараттық-анықтамалық қарапайым жүйе құру талап етіледі. Құрылған
жүйе жұмыс берушілер мен жұмысқа орналасқысы келетіндер жайында тізімді
сақтауы тиіс. Әрбір жұмыс берушіде бірнеше вакансия болуы мүмкін. Әрбір
ізденушіде (қызметке орналасқысы келетін адамда) бірнеше резюме болуы
мүмкін. Сонымен қатар, жүйе қызмет берушілерге қызметкерлерді таңдауға, ал
ізденушілерге жұмыс орнын табуға көмектесуі тиіс.

Конфигурациялау нысандары
Конфигурацияда келесі нысандарды құру талап етіледі:

Нысандар түрлеріНысандар
Анықтамалықтар Жұмыс берушілер
Жұмыс іздеушілер
Вакансиялар
Резюме
Қызметтер
Бөлінулер БілімТүрі
ЖұмысГрафигі
Жынысы
Өңдеулер БазаныТазарту

Қызмет берушілер анықтамалығы
Бұл анықтамалық өз вакансияларын ұсынатын фирмалар, жеке кәсіпкерлер
жөнінде мәліметтерден тұрады.

Сурет Қызмет берушілер анықтамалығының кестесі

Осы кестеде кез-келген жолдың үстінен тышқанмен екі рет түртсек,
келесі форманы аламыз:

Сурет Қызмет берушілер анықтамалығының формасы
Қызмет берушілер анықтамалығының формасының модулі:

Процедура ВакансииРаботодателя()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("НайденныеВакан сии");
Таб.ВывестиСекцию("Все");
СпрВакансии = СоздатьОбъект("Справочник.Вакансии" );
НомПП = 0;

СпрВакансии.ВыбратьЭлементыПоРеквиз иту("Работодатель",ТекущийЭлемент() ,0,0);

Пока СпрВакансии.ПолучитьЭлемент()=1 Цикл
НомПП = НомПП + 1;
Таб.ВывестиСекцию("Вакансия");
КонецЦикла;
Таб.ВывестиСекцию("Все");
Таб.ТолькоПросмотр(1);
Таб.Показать();
КонецПроцедуры

Жұмыс іздеушілер анықтамалығы
Бұл анықтамалық өз резюмелерін ұсынатын жұмыс қарастырушылардан
тұрады.

Сурет Қызмет қарастырушы анықтамалығының кестесі

Осы кестеде кез-келген жолдың үстінен тышқанмен екі рет түртсек,
келесі форманы аламыз:

Сурет Қызмет қарастырушы анықтамалығының формасы

Қызмет қарастырушылар анықтамалығының формасының модулі:

Процедура РезюмеСоискателя()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("НайденныеРезюм е");
Таб.ВывестиСекцию("Все");
СпрРезюме = СоздатьОбъект("Справочник.Резюме");
НомПП = 0;

СпрРезюме.ВыбратьЭлементыПоРеквизит у("Соискатель",ТекущийЭлемент(),0,0 );
Пока СпрРезюме.ПолучитьЭлемент()=1 Цикл
НомПП = НомПП + 1;
Таб.ВывестиСекцию("Резюме");
КонецЦикла;
Таб.ВывестиСекцию("Все");
Таб.ТолькоПросмотр(1);
Таб.Показать();
КонецПроцедуры
Резюме анықтамалығы
Бұл анықтамалық қызмет қарастырушылардың резюмесінен тұрады.

Сурет Резюме анықтамалығының кестесі

Осы кестеде кез-келген жолдың үстінен тышқанмен екі рет түртсек,
келесі форманы аламыз:

Сурет Резюме анықтамалығының формасы

Резюме анықтамалығының формасының модулі:
Перем Конт;
Процедура ПриЗаписи()
Наименование = СокрЛП(Должность.Наименование) + ". Зп от " +
ЗарплатаОт;
КонецПроцедуры
Процедура ПоискВакансии()
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("НайденныеВакан сии");
Таб.ВывестиСекцию("Все");
СпрВакансии = СоздатьОбъект("Справочник.Вакансии" );
НомПП = 0;
СпрВакансии.ВыбратьЭлементы();
Пока СпрВакансии.ПолучитьЭлемент()=1 Цикл
Если СпрВакансии.ПометкаУдаления()=1 Тогда
Продолжить;
КонецЕсли;
Если Должность СпрВакансии.Должность Тогда
Продолжить;
КонецЕсли;
Если ЗарплатаОт СпрВакансии.ЗарплатаДо Тогда
Продолжить;
КонецЕсли;
Если СпрВакансии.ГрафикРаботы.Выбран()=1 Тогда
Если ГрафикРаботы СпрВакансии.ГрафикРаботы Тогда
Продолжить;
КонецЕсли;
КонецЕсли;
Если СпрВакансии.ВидОбразования.Выбран() =1 Тогда
Если ВидОбразования СпрВакансии.ВидОбразования Тогда
Продолжить;
КонецЕсли;
КонецЕсли;
Если СпрВакансии.Пол.Выбран()=1 Тогда
Если Соискатель.Пол СпрВакансии.Пол Тогда
... жалғасы
Ұқсас жұмыстар
Есептің қойылуы туралы ақпарат
Сана проблемасының философияда қойылуы
Философия тарихында рух мәселесінің қойылуы
Экспериментальдық есептердің қойылуы мен шығару әдістемелерін талдау
Бухгалтерлік есептің концепциясы
Бухгалтерлік есептің пайда болуы
Бухгалтерлік есептің ұымдастырылуы
Бухгалтерлік есептің шоттары
Бухгалтерлік есептің концептуалды негіздері
Бухгалтерлік есептің принциптері
Пәндер

Қазақ тілінде жазылған рефераттар, курстық жұмыстар, дипломдық жұмыстар бойынша біздің қор №1 болып табылады.

Байланыс

Qazaqstan
Phone: 777 614 50 20
WhatsApp: 777 614 50 20
Email: info@stud.kz
Көмек / Помощь
Арайлым
Біз міндетті түрде жауап береміз!
Мы обязательно ответим!
Жіберу / Отправить

Рахмет!
Хабарлама жіберілді. / Сообщение отправлено.

Email: info@stud.kz

Phone: 777 614 50 20
Жабу / Закрыть

Көмек / Помощь