Есептің қойылуы туралы ақпарат


Шағын кәсіпорындардың шығыны мен кірісін есепке алатын программалық жүйе құру. Бұл жүйе кәсіпорынның әрбір қызметкерінің шығындары мен кірістерін көрсетуі қажет.

Конфигурациялау нысандары

Конфигурацияда келесі нысандарды құру талап етіледі:
Ең алдымен анықтамалықтар құрылады:
• Қатысушылар
• Қаржылар
• Шығындар статьялары
• Пайдалар статьялары
Құжаттар:
• Пайда
(кесте реквизиттері: Қатысушы, Статья, Қаржы, Сумма)
• Шығын
(кесте реквизиттері: Қатысушы, Статья, Қаржы, Сумма)
• Аударымдар
• БастапқыҚалдықтардыЕнгізу
(кестелік бөлік реквизиттері: Қаржы, Сумма)

Пән: Информатика
Жұмыс түрі: Материал
Көлемі: 5 бет
Бұл жұмыстың бағасы: 300 теңге




Есептің қойылуы

Шағын кәсіпорындардың шығыны мен кірісін есепке алатын программалық
жүйе құру. Бұл жүйе кәсіпорынның әрбір қызметкерінің шығындары мен
кірістерін көрсетуі қажет.

5.3 Конфигурациялау нысандары

Конфигурацияда келесі нысандарды құру талап етіледі:
Ең алдымен анықтамалықтар құрылады:
• Қатысушылар
• Қаржылар
• Шығындар статьялары
• Пайдалар статьялары
Құжаттар:
• Пайда
(кесте реквизиттері: Қатысушы, Статья, Қаржы, Сумма)
• Шығын
(кесте реквизиттері: Қатысушы, Статья, Қаржы, Сумма)
• Аударымдар
• БастапқыҚалдықтардыЕнгізу
(кестелік бөлік реквизиттері: Қаржы, Сумма)
Құжаттар журналдары:
• Барлық құжаттар
Регистрлер:
• Қаржылар (қалдықтар регистрі)
• Кірістер (кері регистр)
• Шығындар (кері регистр)
Есептер:
• Қалдықтар
• ПайдаларШығындар
Қатысушылар анықтамалығы
Бұл анықтамалық қаржы жүргізілетін барлық қызметкерлердің аты-жөндері
мен мәліметтерінен тұрады.

Сурет Қатысушылар анықтамалығының түрі
Қаржылар анықтамалығы
Бұл анықтамалық қызметкерлердің қаржыларын аудару, сақтау орындары
туралы мәліметтер береді.

Сурет Қаржылар аныктамалығының түрі

Пайдалар статьялары анықтамалығы
Бұл анықтамалық ұжым тобының пайда көздерінің атауларынан тұрады.

Шығындар статьялары анықтамалығы
Бұл анықтамалық кәсіпорынның жұмсайтын шығындарын көрсетеді.

Сурет Шығындар статьялары анықтамалығының түрі
Конфигурациядағы құжаттар түрлері
Бастапқы қалдықтарды енгізу құжаты

Бұл құжаттың экрандық формасы келесі түрде болады:

Егер осы құжатта бірде-бір жолды толтырмасақ, Қаржы көзі немесе
Сомасы жолдарын толтырмасақ, онда келесі қате жөніндегі ескертулерді
аламыз:

Сурет Қаржы көзі жолы толтырылмаған кездегі ескерту

Сурет Сомасы жолы толтырылмаған кездегі ескерту

Сурет Формадағы бірде-бір жол толтырылмаған кездегі ескерту
Бастапқы қалдықтарды енгізу құжатының формасының модулі келесі түрде
болады:

Процедура ВводНового()
Автор = ИмяПользователя();
КонецПроцедуры

Процедура ПриЗаписи()
Если КоличествоСтрок()=0 Тогда
Предупреждение("Бірде-бір жол корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Кошелек.Выбран()=0 Тогда
Предупреждение("Строка " + НомерСтроки + " Каржы
корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;

Если Сумма=0 Тогда
Предупреждение("Строка " + НомерСтроки + " Сома
корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;

КонецЦикла;
Автор = ИмяПользователя();
АвтоВремяТекущее();
КонецПроцедуры

Бастапқы қалдықтарды енгізу құжатының формасын өткізу модулі келесі
түрде болады:

********************

Процедура ОбработкаПроведения()
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Регистр.Кошельки.Кошелек = Кошелек;
Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеПриходВыпо лнить();
КонецЦикла;
КонецПроцедуры

Пайда құжаты
Бұл құжаттың экрандық формасы келесі түрде болады:

Сурет Пайда құжатының формасының түрі
Осы құжатта Қатысушы жолы толтырылмаса келесі ескертуді аламыз:

Сурет Қатысушы жолы толтырылмаған кездегі ескерту

Сурет Статья жолы толтырылмаған кездегі ескерту

Сурет Қаржысы жолы толтырылмаған кездегі ескерту

Сурет Сомасы жолы толтырылмаған кездегі ескерту
Пайда құжатының формасының модулі келесі түрде болады:

Процедура ВводНового()
Автор = ИмяПользователя();
КонецПроцедуры

Процедура ПриЗаписи()

Если Участник.Выбран()=0 Тогда
Предупреждение("Катысушы корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;

Если Статья.Выбран()=0 Тогда
Предупреждение("Статья корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;

Если Кошелек.Выбран()=0 Тогда
Предупреждение("Каржысы корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;

Если Сумма=0 Тогда
Предупреждение("Сомасы корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Автор = ИмяПользователя();
АвтоВремяТекущее();
КонецПроцедуры

Пайда құжатының формасын өткізу модулі келесі түрде болады:

********************

Процедура ОбработкаПроведения()
Регистр.Доходы.Участник = Участник;
Регистр.Доходы.Статья = Статья;
Регистр.Доходы.Сумма = Сумма;
Регистр.Доходы.ДвижениеВыполнить();

Регистр.Кошельки.Кошелек = Кошелек;
Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеПриходВыпо лнить();
КонецПроцедуры

Шығын құжаты

Сурет Шығын құжатының формасының түрі

Осы құжатта кейбір жолдар толтырылмаса келесі ескертулер аламыз:

Сурет Қатысушы жолы толтырылмағандағы ескерту

Сурет Статья жолы толтырылмағандағы ескерту

Сурет Қаржысы жолы толтырылмағандағы ескерту

Сурет Сомасы жолы толтырылмағандағы ескерту

Шығын құжатының формасын өткізу модулі келесі түрде болады:
Процедура ВводНового()
Автор = ИмяПользователя();
КонецПроцедуры
Процедура ... жалғасы
Ұқсас жұмыстар
Есептің қойылуы
Бухгалтерлік есептің принциптері туралы
Сана проблемасының философияда қойылуы
Ақпарат туралы
Бухгалтерлік есеп туралы ақпарат
Аудит туралы ақпарат
Философия тарихында рух мәселесінің қойылуы
Инвестициялар туралы ақпарат
Ақпарат туралы түсінік
Кәсіпкерлік түрлері туралы ақпарат
Пәндер

Қазақ тілінде жазылған рефераттар, курстық жұмыстар, дипломдық жұмыстар бойынша біздің қор №1 болып табылады.

Байланыс

Qazaqstan
Phone: 777 614 50 20
WhatsApp: 777 614 50 20
Email: info@stud.kz
Көмек / Помощь
Арайлым
Біз міндетті түрде жауап береміз!
Мы обязательно ответим!
Жіберу / Отправить

Рахмет!
Хабарлама жіберілді. / Сообщение отправлено.

Email: info@stud.kz

Phone: 777 614 50 20
Жабу / Закрыть

Көмек / Помощь