Есептің қойылуы туралы ақпарат

Шағын кәсіпорындардың шығыны мен кірісін есепке алатын программалық жүйе құру. Бұл жүйе кәсіпорынның әрбір қызметкерінің шығындары мен кірістерін көрсетуі қажет.

Конфигурациялау нысандары

Конфигурацияда келесі нысандарды құру талап етіледі:
Ең алдымен анықтамалықтар құрылады:
• Қатысушылар
• Қаржылар
• Шығындар статьялары
• Пайдалар статьялары
Құжаттар:
• Пайда
(кесте реквизиттері: Қатысушы, Статья, Қаржы, Сумма)
• Шығын
(кесте реквизиттері: Қатысушы, Статья, Қаржы, Сумма)
• Аударымдар
• БастапқыҚалдықтардыЕнгізу
(кестелік бөлік реквизиттері: Қаржы, Сумма)
        
        Есептің қойылуы
Шағын кәсіпорындардың шығыны мен кірісін есепке алатын программалық
жүйе құру. Бұл жүйе ... ... ... ... ... ... ... Конфигурациялау нысандары
Конфигурацияда келесі нысандарды құру талап етіледі:
Ең алдымен анықтамалықтар құрылады:
• Қатысушылар
• Қаржылар
• Шығындар статьялары
• Пайдалар статьялары
Құжаттар:
• Пайда
(кесте реквизиттері: Қатысушы, Статья, ... ... ... ... ... Статья, Қаржы, Сумма)
• Аударымдар
• БастапқыҚалдықтардыЕнгізу
(кестелік бөлік реквизиттері: Қаржы, Сумма)
Құжаттар журналдары:
• Барлық құжаттар
Регистрлер:
• Қаржылар (қалдықтар регистрі)
... ... ... Шығындар (кері регистр)
Есептер:
• Қалдықтар
• ПайдаларШығындар
«Қатысушылар» анықтамалығы
Бұл анықтамалық қаржы жүргізілетін барлық қызметкерлердің аты-жөндері
мен мәліметтерінен ... ... ... ... ... ... ... қаржыларын аудару, сақтау орындары
туралы мәліметтер береді.
Сурет Қаржылар ... ... ... ... ... ұжым ... пайда көздерінің атауларынан тұрады.
«Шығындар статьялары» анықтамалығы
Бұл анықтамалық кәсіпорынның ... ... ... «Шығындар статьялары» анықтамалығының түрі
Конфигурациядағы құжаттар түрлері
«Бастапқы қалдықтарды енгізу» құжаты
Бұл құжаттың экрандық ... ... ... болады:
Егер осы құжатта бірде-бір жолды толтырмасақ, ... көзі ... ... ... онда ... қате ... ескертулерді
аламыз:
Сурет Қаржы көзі жолы толтырылмаған кездегі ескерту
Сурет Сомасы жолы толтырылмаған ... ... ... ... жол ... кездегі ескерту
«Бастапқы қалдықтарды енгізу» құжатының формасының модулі келесі түрде
болады:
Процедура ВводНового()
Автор = ... ... ... ... жол ... ... ПолучитьСтроку()=1 Цикл
Если Кошелек.Выбран()=0 Тогда
Предупреждение("Строка " + НомерСтроки + " Каржы
корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Сумма=0 ... " + ... + " ... ... = ... қалдықтарды енгізу» құжатының формасын өткізу модулі келесі
түрде болады:
// ********************
//
Процедура ОбработкаПроведения()
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Регистр.Кошельки.Кошелек = ... = ... ... ... ... ... келесі түрде болады:
Сурет «Пайда» құжатының формасының түрі
Осы құжатта Қатысушы жолы толтырылмаса келесі ескертуді аламыз:
Сурет Қатысушы жолы толтырылмаған ... ... ... жолы ... ... ескерту
Сурет Қаржысы жолы толтырылмаған кездегі ескерту
Сурет Сомасы жолы толтырылмаған кездегі ескерту
«Пайда» құжатының формасының модулі келесі түрде ... ... = ... ... ... ... корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Статья.Выбран()=0 Тогда
Предупреждение("Статья корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Кошелек.Выбран()=0 Тогда
Предупреждение("Каржысы корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Сумма=0 Тогда
Предупреждение("Сомасы корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Автор = ИмяПользователя();
АвтоВремяТекущее();
КонецПроцедуры
«Пайда» құжатының формасын ... ... ... ... ... ... ... = Участник;
Регистр.Доходы.Статья = Статья;
Регистр.Доходы.Сумма = Сумма;
Регистр.Доходы.ДвижениеВыполнить();
Регистр.Кошельки.Кошелек = Кошелек;
Регистр.Кошельки.Сумма = Сумма;
Регистр.Кошельки.ДвижениеПриходВыполнить();
КонецПроцедуры
«Шығын» құжаты
Сурет ... ... ... ... ... кейбір жолдар толтырылмаса келесі ескертулер аламыз:
Сурет Қатысушы жолы толтырылмағандағы ... ... жолы ... ескерту
Сурет Қаржысы жолы толтырылмағандағы ескерту
Сурет Сомасы жолы толтырылмағандағы ескерту
«Шығын» құжатының формасын өткізу модулі ... ... ... ... = ... ... Участник.Выбран()=0 Тогда
Предупреждение("Катысушы корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Статья.Выбран()=0 Тогда
Предупреждение("Статья корсетілмеген!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Кошелек.Выбран()=0 ... ... ... ... ... ... Возврат;
КонецЕсли;
Автор = ИмяПользователя();
АвтоВремяТекущее();
КонецПроцедуры
«Шығын» құжатының формасының модулі келесі түрде болады:
// ********************
//
Процедура ОбработкаПроведения()
Регистр.Расходы.Участник = Участник;
Регистр.Расходы.Статья = ... = ... = ... = ... ... ... ... формасы келесі түрде болады:
Сурет Аударымдар құжатының экрандық формасы
Осы құжатта толтырылмаған жолдар болса келесі ескертулер аламыз:
Сурет ... ... орын жолы ... ... ескерту
Сурет Қаржы аударатын орын жолы толтырылмаған кездегі ескерту
Сурет Сомасы жолы ... ... ... ... Қалдықтар есебінің формасының түрі
Қалдықтар есебінің формасын өткізу модулі:
Процедура Сформировать()
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса = "
|Кошелек = Регистр.Кошельки.Кошелек;
|Участник = Регистр.Кошельки.Кошелек.Участник;
|Сумма = ... ... ... = ... в ... в ВыбрУчастник);
|";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Все");
Таб.Показать();
КонецПроцедуры
«Пайда мен шығындар» есебі
Сурет Пайда мен ... ... ... мен ... ... ... өткізу модулі:
Перем ИмяРегистра;
Перем ИмяСправочникаСтатей;
Процедура УстТипОтчета()
Если ТипОтчета=1 Тогда
ИмяРегистра = "Доходы";
ИмяСправочникаСтатей = ... = ... = ... + ... ... ... ИЛИ ... Тогда
Предупреждение("Не указан период!");
Возврат;
КонецЕсли;
Таб = СоздатьОбъект("Таблица");
Таб.ВывестиСекцию("Все");
Таб.Показать();
КонецПроцедуры
Процедура ПоменятьГруппировкиМестами(Ном1,Ном2);
стр = "";
Значение1 = СписокГруппировок.ПолучитьЗначение(Ном1,стр);
Пометка1 = СписокГруппировок.Пометка(Ном1);
Значение2 = СписокГруппировок.ПолучитьЗначение(Ном2,стр);
Пометка2 = СписокГруппировок.Пометка(Ном2);
СписокГруппировок.УстановитьЗначение(Ном1,Значение2);
СписокГруппировок.Пометка(Ном1,Пометка2);
СписокГруппировок.УстановитьЗначение(Ном2,Значение1);
СписокГруппировок.Пометка(Ном2,Пометка1);
КонецПроцедуры
Процедура Вверх()
ТекСтрока = ... ... = 1 ...

Пән: Информатика
Жұмыс түрі: Материал
Көлемі: 5 бет
Бұл жұмыстың бағасы: 300 теңге









Ұқсас жұмыстар
Тақырыб Бет саны
Есептің қойылуы4 бет
Delphi бағдарламалау ортасына сипаттама48 бет
Delphi –программалық ортасында бағдарламалау17 бет
JavaScript- та бағдарламалау25 бет
OpenFOAM пакетің қолданып, көпфазалы ағындарды модельдеу22 бет
«Үш биік» ЖШС-ң менеджерінің АЖО жасау92 бет
Ірі құйындар әдісімен пішіндеу12 бет
Алгоритмдеу және бағдарламалау негіздері19 бет
Ақпаратты өңдеу жүйесіндегі программалық қамтамасыз ету30 бет
Бағдарламалау аймағын таңдау және негіздеу60 бет


Исходниктер
Пәндер
Көмек / Помощь
Арайлым
Біз міндетті түрде жауап береміз!
Мы обязательно ответим!
Жіберу / Отправить


Зарабатывайте вместе с нами

Рахмет!
Хабарлама жіберілді. / Сообщение отправлено.

Сіз үшін аптасына 5 күн жұмыс істейміз.
Жұмыс уақыты 09:00 - 18:00

Мы работаем для Вас 5 дней в неделю.
Время работы 09:00 - 18:00

Email: info@stud.kz

Phone: 777 614 50 20
Жабу / Закрыть

Көмек / Помощь