Оқу залының жұмысын жеңілдететін автоматты басқару жүйесін жасау атты дипломдық жұмысқа арналған патенттік-ақпараттық зерттеулер

Дипломдық жоба тақырыбы: Оқу залының жұмысын жеңілдететін автоматты басқару жүйесін жасау

Ізденістің басталуы 3.04.2008 ж,. аяқталуы 29.04.2008 ж.
Жетілдірілетін нысанның қысқаша сипаттамасы.
 Көп жүйелілік. Мәліметтер базасында пациенттермен жұмыс жүргізуге арналған әр түрлі салалы жүйе болуы қажет.
 Есепке алу модулі құрлыс компаниясының жұмысшылары мен қызметкерлерінің барлық мәліметтерін бір жүйеге біріктіріп, бүртұтас программалық жүйе құра алуы және осы аталған мәліметтер жөнінде есептер жүргізе алуы тиіс.
 Жүйенің максималды икемділігі және конфигурациялау жылдамдығы.
 Басқа программалық жабдықтармен бірге жұмыс жасай алуы.
 Есептерді құрастырудың тиімді жүйесі. Есептер шаблондарын қолданушының өздігінен енгізуіне мүмкіндік беруі.

Осы сферадағы ұқсас программалар туралы мағлұматтар:
2002 жылдың 5 қарашасында Ресейдің жеке ой, патент және тауарлық таңбалар жөніндегі федеральды қызметі Автоматтандырылған ақпараттық- кітапханалық жүйе MAРК-SQL программасын заңды түрде тіркеп, сәйкес куәлік берді.
Томск аумағында қалалық кітапханалар АЖО «Кітапхана», АЖО «Абономент» программаларын жетістікпен қолданып келеді.
Программаның кемшіліктері – сертификаты жоқ, авторлық куәлігі тіркелмеген. Артықшылықтары программаны ақысыз жаңарту, жұмыстың тиімділігі.
Осы дипломдық жобада істелген жұмысқа қарап, біз бұл программаның тек қана бухгалтерлік есептеулер ғана жүргізбейтінін, яғни оның конфигурациясын өзгерте отырып, қоғамның әр түрлі салаларына арналған программалар құруға болатынына көз жеткізуге болады.
        
        Кіріспе
Дамудың әрбір кезеңінде адамзаттың алдында ақпаратты ... және ... ... тұрды. Көп уақыт бойы осы мәселені шешудің
негізгі құралдары ретінде адам миы, тіл және есту ... ... Ең ... ... жазу өнерінің келуімен, одан соң кітап басудың
шығуымен болды. Осы ... ... ... ... ... ... жағдай ЭЕМ-нің келуімен түбірімен өзгерді. ... ... ... арифмометрлер ретінде қолданылды. Бұл қадам адам қызметінің
ақпаратты өңдеудегі негізгі бөлім болып табылатын кешенді автоматтандыруға
ауысты.
ЭЕМ-рын жүйелік ... ... ... бір мысалына
мәлеметтерді өңдеу жүйесін, ... ... ... бухгалтерлік
есептерді, билеттерді өңдеуді автоматтандыру жатады. Осындай операциялардың
тиімділігі автоматтандырылған ақпараттық базаларға сүйенеді. Бұл ... ... ... ... қажетті ақпарат сақталады.
Кезекті есепті шешу кезінде жүйе көп емес қосымша ақпаратты еңгізуді
ғана қажет етеді, ал қалғаны ... ... ... ... ... ақпараттың әр бір бөлігі жүйенің ақпараттық базасын өзгертеді.
Ақпараттың ЭЕМ-ң жадысында сақталуы оған жаңа ... ... ... ... автоматты баспаға шығару қызметі қажетті ... ... ... бойынша кез-келген мәліметті қағазға шығарып береді.
Адамзат дамуының XXI ғасырында ақпарат негізгі қызметтік өнім болып
табылады. Сондықтан кітапханалық ... ... ... жасау негізгі мәселе деп ойлаймын.
Әдетте кітапхана оқырмандары кітапханадан кез-келген ақпаратты алуға
үйренген. Қазір, кітапханада ... ... ... яғни ... ақпараттық – библиографиялық және абонементік қамтамасыз ету
күрделене ... ... ... ... ... ... ... сақтау
және қамтамасыз ету үшін, ол бір ақпараттық база ... ... ... ... іздеу жылдамдығы жоғарылауы қажет.
Автоматтандырылған кітапханалық ақпараттық жүйелердің ... ... ... рет ... және құжаттарды іздеуге жиі қолдану,
таңдалған ақпаратты баспаға ... ... ... ... т ... Қосымша картотекалар мен нұсқаларды қолданбай мәліметерді әр түрлі
жағдайда іздестіру;
• Кітапханада өтетін ... ... ... ... фактографиялық жазбаларды дайындау;
• Басылым экземплярының қолда екенін көрсететін мәліметтерді шығару;
• Оқулық авторларының және ... ... ... ... Оқырманға басылымдарды іздестіру үстінде туындаған қиындықтарға арналған
анықтамалық текстердің болуы;
... ... ... ... жөнінде және олардың кітапханаға
түсуі туралы жазбаларды еңгізу;
... ... ... ... экрканға және принтерге шығару;
• Бөгде қолданушылардан мәліметтер базасын қорғау;
... ... ... ... ... келтіру.
Берілген дипломдық жұмыстың мақсаты білім беру саласындағы кітапханалық
бөлімдердің, оқу ... ... ... ... ... ... анықталған информация құрылымымен басқаруға
және оқу бөлімі үшін анықталған және ... ... ... ... ... қатар келешекте қолданушыларға деректер базасымен және
олармен басқару жүйелерін зерттеуге көңілін алаңдатпауға ... ... ... ... ... ... ... актуалды тақырыбынің құрылымы казіргі ... ... ... ... ... ... беретін,
оқушылар контингентінің жылжуын қадағалайтын, анықталған ... ... ... ... ... ... ... жүйе өте маңызды ... ... ... ол ... үлкен контингенті кезінде оқу бөлімі
секретарінің автоматтандырылған ... орны ... іс ... ... және ... жұмыс істеудің ыңғайлы құралы болып
табылады. ... ... ... ... үшін ... да ... ДББЖ-нің құралдарын пайдалынбай,Windows-та жұмыс істейтін,
интерфейсі ыңғайлы жұмыс істеу үшін максималды икемденген, қосымша ... ... ... файл ... ... жеке ... ... Осы талаптарға сәйкес мына дипломдық ... ... ... жету ... ... шешуге мүмкіндік береді:
- студенттердің жеке кәртешкелерін толтыру;
- оқытушылардың және оқытылатын пәндер аттарының тізімін толтыру;
- ... ... оқу ... ... ... ... ... оқуға тіркеу, оқудан шығару құжаттарын жүргізу;
- сынақ, емтихан бағалары туралы құжаттарын жүргізу;
- есеп беру құжаттарын ... ... ... ... ... ... ... құрама ведомосін, оқушылар тізімін,
оқушылардың кәртешкелерін.
Дипломдық жұмыстың зерттеу пәні, негізі информациялық және ... ... ... ... ... ... болатын процестерді
автоматизациялау болып табылады.
1 Сұрақтың қойылуы
Шәкәрім атындағы ... ... ... және ... ... меңг. ___________ А.Д.Золотов
«___» _________________ 2008 ж.
(дата) ... ... ... ... ... ... жоба тақырыбы: Оқу залының жұмысын жеңілдететін автоматты басқару
жүйесін жасау
Ізденістің басталуы 3.04.2008 ж,. аяқталуы 29.04.2008 ж.
Жетілдірілетін ... ... ... Көп жүйелілік. Мәліметтер базасында пациенттермен жұмыс ... әр ... ... жүйе ... ... ... алу модулі құрлыс компаниясының жұмысшылары мен қызметкерлерінің
барлық мәліметтерін бір ... ... ... ... жүйе
құра алуы және осы аталған мәліметтер жөнінде есептер жүргізе алуы тиіс.
← Жүйенің максималды икемділігі және конфигурациялау жылдамдығы.
← Басқа ... ... ... ... ... ... Есептерді құрастырудың тиімді жүйесі. Есептер шаблондарын қолданушының
өздігінен енгізуіне мүмкіндік беруі.
Осы сферадағы ұқсас программалар туралы мағлұматтар:
2002 жылдың 5 ... ... жеке ой, ... және тауарлық таңбалар
жөніндегі федеральды қызметі Автоматтандырылған ақпараттық- кітапханалық
жүйе ... ... ... түрде тіркеп, сәйкес куәлік берді.
Томск аумағында қалалық кітапханалар АЖО «Кітапхана», АЖО «Абономент»
программаларын жетістікпен қолданып келеді.
Программаның ...... жоқ, ... ... ... ... ... жаңарту, жұмыстың
тиімділігі.
Осы ... ... ... ... ... біз бұл ... тек
қана бухгалтерлік есептеулер ғана жүргізбейтінін, яғни оның конфигурациясын
өзгерте отырып, қоғамның әр түрлі салаларына ... ... ... көз жеткізуге болады.
Операциялар журналына өткізулерді енгізген соң, ... ... ... үшін ... ... қажет. Бұл бағдарламаның
тағы бір ... ...... ... жоспарларын жүргізу
мүмкіндігі. Бухгалтерия жоспары – бұл ... ... ... ... бланкілер, типтік операциялар, аналитикалық белгілері және
т.б.), яғни әртүрлі бірнеше кәсіпорындарды бір ... бір ... ... үшін ... ... болады. Бұл мәліметтердің
артуына әкелмейді, себебі әртүрлі фирмалар, мысалы: ... ... ... ... ... ... ... барысында жүргізілген
патенттік зерттеулер бойынша
Диплом жобасының тақырыбы – «Оқу залының ... ... ... жүйесін жасау»
Іздеу тереңдігі: 2001 жылдан 2006 жылға дейін
1. Патенттік зерттеулер жүргізу алдында ... ... ... ме? ... ... ... ... қол жетті, ізденіске сай келетін ақпарат яғни аналогтар табылды.
2. ... ... ... ... ... № А12 ... Ресей Патент № С 45 D 45/25, 1/12 патенті бойынша анықталды.
Табылған аналогтарының ... ... ... ... ... ... Патент № Ғ 98 K 1/00, 1/12 бойынша , оқу ... ... ... жүйесі анықталды
Диплом жобасында ... ... ... ... ... сериялап шығаратын қандай еліміздегі және шет елдердегі
фирмалар ... ... және ... ... ... ... ... шығаратын Қазақстан фирмалары табылған
жоқ.
Тапсырма берілді ... ... ... Темиртасов А.
(қолы)
(аты-жөні)
Дипломдық жоба жетекшісі ____________ Р.С. ... ... ... ... ... дипломдық жобада оқу залы жүйесінің автоматтандырылуы
қарастырылды. ... ... сол ... ... ... техника бұйымдарының ... және ... ... ... ... ... болғандықтан базалық
нұсқа ретінде жасалынатын өлшеу жүйелерінің біреуін таңдау керек. Оптималды
еңбек ... құру ... ... ... ... ... және ... уақытын үнемдейтін жұмыс орнын
дұрыс ... ... ... ... ... ақпараттық-басқарушы жүйені құрудың маңызын
арттыру үшін, оны ... ... ... ... және ... ... жоспарланғаны дұрыс. Бұл жағдайда жүйенің ақпараттық-
басқарушы жүйесін ... ... ... ... жұмысына және
желіні жүктеуге кеткен машиналық уақыттың ақысына жұмсалған ... + Шмаш ... ...... ... ... ... – программаны құрушының еңбек ақысына кеткен шығындар,
Шмаш – машиналық уақыт ақысына ... ... да ... ... өзіндік құнын есептеу кезінде дәлме-
дәл есептеу әдісі ... ... ... (дәлме-дәл есептеу) әртүрлі әдістерін
қолданылады:
- тура
- есептеу-аналитикалық
- параметрлік
- комбинацияланған
- қайта бөлу
Бұлардың ішінде кеңінен таралғаны - ... ... ... ... ... ... интерфейсті программаның өзіндік құнын
есептеу үшін қолданылуы керек.
Бізге ... ... ... ... калькуляция
статьясының келесі құрамы қабылдануы керек:
1. Материалдар
2. Қайтарылмалы қалдық (алынып тасталынады)
3. Сатып алынатын комплектеуші бұйымдар, жартылай фабрикаттар және ... ... ... негізгі еңбек ақысы (еңбек ақы қорынан алынатын
сыйақыларды қоса ... ... ... ... ... ақысы
6. Өндіріс жұмысшыларының еңбек ақысынан әлеуметтік сақтандыруға кететін
салымдар
7. Өндірісті дайындауға және игеруге кететін ... ... ... ... мен ... ... және арнайы
шығындар
Зерттелетін жүйе программалық қамсыздандыруының өзіндік құны
жобалаудың ... ... ... Бұл ... ... ... дәлме-дәл
өлшеуге қажетті бастапқы мәліметтердің біразы болады ... ... ... ... құнын есептеу кезінде дәлме-дәл есептеу
әдісі қолдануы керек.
3 ... ... орны ... және ... ... басқару жабдықтарын қызметтік салаға енгізудің жанашыл
түрлері кешенді түрде ... ... ... алмасуға мүмкіндік
береді.
Кейінгі кезде әртүрлі қызмет салаларын жан-жақты басқару жүйелері,
яғни ақпаратты ... ... ... Жан-жақты басқару тәсілін
жетілдіру үшін әрбір басқарылатын деңгейге арнайы жеке ... ... ... ... құру қажет.
Мамандар автоматтандырылған жұмыс ... ... ... ... ... ... ... автоматтандыру мақсатында орналастырылған
арнайы кіші есептеу жүйелері ретінде қарастырады.
Әрбір басқару нысаны үшін олардың функционалдық ... ... ... ... ... ... автоматтандырылған жұмыс
орнын (АЖО ) құру принциптері жалпы болуы қажет: жүйелі, икемді, тиімді.
АЖО-ның жүйелік принципін ... ... ... ... ретінде қарастырады.
Икемділік принципі жүйенің мүмкін ... ... ... ... ... АЖО ... оған әсер ... ішкі және сыртқы
факторларға қарамастан негізгі ... ... ... Бұл
дегеніміз оны жекелеген бөліктеріндегі ақаулар жылдам жөнделіп, ал жүйенің
жұмыс қабілеттілігі тез қалпына келтірілуі болып ... ... ... ... ... құру және
эксплуатациялық шығындарына ... ... ... ... таралу
деңгейінің интегралды көрсеткіші ретінде қарастырады.
Енді ЭЕМ-ң базасындағы АЖО-ң даму перспиктивасын және жағдайын, содан
соң АЖО-ң техникалық программалық ... ... ... ... ... ... жаңа класының жеке ЭЕМ-ң
дамуына ... Жеке ... ... ...... ... және
жоғары өнімділігі. Осы күні әр түрлі мамандықты мамандарды ой және ... ... үшін жеке ... ... құрылған АЖО-ны жасау кең
қолданылды.
Сурет 3.1 Жеке ЭЕМ-ң жалпыланған сұлбасы
1–микропроцессор, 2–негізгі жады, ... ... ... ... ... ... ... АЖО-н құрайтын негізгі элеметтерді қарастырайық ... ... ... ... ... ... сұлбасы көрсетілген.
Жеке ЭЕМ-ң негізгі құрылғысы ... ... ... ... болып табылады. Микропоцессордың разрядтығы екілік
кодтағы сөздің ұзындығын білдіреді. Сонымен ... олар ... ... ... Процессордың тактілік жилігіне разрядтығы
неғұрлым жоғары болса, өнімділігі де жоғары болады. Жеке ... ... ... ... ... орындау үйреншікті жағдай болып
табылады.
ЖЭЕМ-ң өнімділігі ол жұмыс істейтін жады мөлшеріне де ... ... және ... ... . ... жады екі ... тұрады: тұрақты
есте сақтау құрылғысы (ROM немесе ТЕСҚ) және жедел есте ... ... ... ... ... ... ақпараты және өңделетін
мәліметтер сақталады .Қорек ажырағанда ... ... ... ... ЕСҚ –на ... ... ондағы ақпарат тұрақты сақталады. ... тек ... ... іске ... ... 8
разрядты ЭЕМ-да 64Кб –640Кб,16 разрядтыда-1Мб,32 разрядтыда –4МБ және одан
жоғары.Сыртқы есте ... ... әр ... ... ... ақпаратт магниттік лентада сақтау үшін қажет.Қазір олар
бірнеше гигабайт (1Гб(1024Мб) ақпаратты ... ... өте ... ... ... да үлкен сұранысқа ие.Дисктік
жинақтағыштарды бірнеше ... ... ... ... ... ... (флоппи дисктер). Дискеталар
сыйымдылығы аз болса да ... ... ... сұранысқа ие.
2 Қатаң дисктердегі жинағыштар(винчестерлер). Олар да кең ... беру ... өте ... жоғары, ақпаратты
сақтау тұрақтылығы үлкен.Винчестерлердің бағасы ... ... ... ... ... ... (СD-ROM)жинақтағыштар.Бірқатар кемшіліктеріне
қарамастан (мәліметтерді алмау) СD-ROM-да ақпаратты сақтау жабдығы ретінде
көп пайдаланылады.Артықшылығы: көп көлемді ... ...... ... арналған негізгі құрылғы.
Клавиатура – ақпаратты еңгізуге арналған негізгі құрылғы.
Жинақталған тәжірибелер АЖО– ң ... ... ... ... Маманның ақпараттық және есептеу ... өз ... ... ... аз ... жауап беру;
• Қолданушының дайындық деңгейіне және кәсіби ... ... ... ... ... меңгеру қарапайымдылығы және қамтамасыз ету
оңайлығы;
• Есептеу желісінде жұмыс істеу мүмкіндігі.
3.2–суретте АЖО –ң жалпыланған сұлбасы көрсетілген.
Сурет 3.2 ... ... ... сұлбасы
Жалпы программалық қамсыздандыру (ПҚ) ... ... жаңа ... ... және ... ... кәсіби бағдары ПҚ –ң функционадық ... ... ... ... бір ... ... ... нақты бір есептер шешіледі.
Функционалдық ПҚ-ды жасау кезінде ... мен ... ... ... Қолданушыға ЭЕМ-да жұмыс істеудің қызықты әрі
тартымды болуы оның пайдалы, қажетті іспен айналасуына байланысты.
АЖО – н ... ... ... ... талдау оларды
қолданушы мен машина арасындағы байланыс принципіне қарай келесі топтарға
бөлінеді:
1. Командалық тілді жүйелер
2. ... ... ... ... ... диалог»
Қолданбалы жүйелерді командалық тілді қодану – мини - және микро ЭЕМ ... үшін ... ... ... Оның ...... тарату оңайлығы, кемшлігі – командалар мен оның параметрлерін сақтау
қажеттігі, қате ... ... әр ... ... ... шектелуі. «Адам нысандар әлемінде» тобында арнайы командалар жоқ,
мұнда адам ... ... ... ... курсорды клавиша арқылы
басқарып немесе арнайы ... ... ... ... ... диалог тұтынушыға бірнеше ... ... ... ол ... ... таңдай алады. Қазіргі уақытта соңғы екі топтан
тұратын қолданушы интерфейсі кең ... ... ... ... ... ... ... (әдетте экранның үстіңгі жағында орналасады)
жол немесе меню жолағы деп ... Оның ... ... әр ... ... ... Екінші бөлік (төменде орналасады немесе кейбір
программаларда оның болмауы мүмкін) жағдай жолы деп аталады. ... ... ... деп ... Адам мен ... ... ... диалогты
ұйымдастыру формасы барлық жаңашыл программаларда қолданылады.
Қазіргі кезде текстік редакторлардың,кестелердің, ... ... ... ... ... көп ... Сондықтан , текістік және графикалықақпарат ... бір ... үшін ... ... ... ... ( МББЖ ) ... .
Сондықтан кәсіби бағыттағы ... ... көшу ... ... .Ол
келесілерден тұрады :
• Шешілетін есептерді белгілеу
• Басқа қызметкерлермен ... ... ... ... Арнайы техникалық жабдықтарды қолдану (тышқан, желі, ... ... ... алу ... мұндай АЖО-мен жабдықтау мекеме ... ... ... ... ... , сонымен қатар тиімді басқаруға
және жоспарлауға ... ... ... ... ... арттырады.
Енді Қазақстандық нарықтағы кітапханаларға арналған программалық
комплекстерді қарастырайық.
4 АЖО-н жасауға арналған оптималды бағыттарды ... ... ... ... АЖО ... ... туралы ақпаратты өңдеу, енгізу,
сақтау үшін қолданылады. Осындай АЖО-н ... ... ... көп ... ... ... ... және жедел түрде алуға мүмкіндік береді.
• Мәліметтерді енгізуді оңайлатады.
• Есептерді тез алуға көмектеседі.
• Оқырманға басылым туралы ақпаратты ... әрі дәл ... ... ...... жасалғандықтан ең алдымен
Қазақстан нарығындағы осы программаның алатын орны мен маңызды ... ... жөн ... ... ... бір-екі бөлімді осы
программаның нарықтағы рөліне арнаймын.
4.1.1 Қазақстан нарығындағы бухгалтерияға шолу жасау
4.1.1.1 1С – 1С:7.7 ... ... ... ... кең ... ... бірі 1С:7.7
Бухгалтерлік болып табылады, ол коммерциялық қызметтің кез келген түрін:
көтерме және бөлшектік сауда, комиссиялық ... ... ... ... ... ... ... есептілікпен (регламенттелген) қоса,
бухгалтерлік және салықтық есептіліктерін автоматтандыруға арналған.
Бухгалтерлік есептің әдістемесі шаруашылық операцияның әр ... ... ... ... бойынша сияқты, аналитикалық
есептің қажетті кесімі бойынша бір ... ... ... ... ... ... ... шегінде есептің әдістемесін
басқара алады, жаңа субшоттар аша ... және ... ... ... ... [19].
Егер бухгалтерлік қызмет кәсіпорындағы есепке толық жауапты болса,
мысалы, алғашқы құжаттарды жазу және ... ... ... ... ... ... қызметінің алдында тұрған
барлық ... ... ... ... ... облыс келесі схемамен көрсетілген.
1С:7.7 Бухгалтерлікте ... ... және ... ... ... ... ... деген қолданбалы шешімдермен бірлесіп қолданылу
мүмкіндігі жасалынған, сонымен ... ... ... 8.0»
платформасында да жасалған.
Есепте шаруашылық операцияларды ... ... ... бухгалтерлік
есептің алғашқы құжаттарына сәйкес келетін конфигурация құжаттарын енгізу
болып табылады. Одан ... жеке ... ... ... ... ... ... үшін типтік операцияларды қолданылуға
болады – қолданушымен тез және оңай қалыпқа ... ... ... ... ... бухгалтерлік проводкалар құралады,
оларды тек қана проводкаларға ... ... ... ... Әрбір
проводканың құрылуын журналдан білу өте оңай: проводка жазуының үстінен
тышқанмен екі рет ... ... ... ... ... ... құжаттың
немесе операцияның формасын ашуға болады. Ол А ... А.2 ... ... ... ... қолданыла отырып және
операциялардың немесе құжаттардың формасын шақыру жолымен осы немес ... ... ... ... есептің берілгендерімен жұмыс
істей алады. Бірақ, ... ... ... ... ... кез келген
есептілік периодының ұзақтығында проводкалардың ... саны ... ... ... бұндай әдісі рентабельді болмай
шығады.
Тауарлық – ... ... ... (ТМҚ) ережеге сай,
ақпараттың үлкен ... ... ... ... ... конфигурациясы мәліметтерді ... ... және ... ... ... ... бір ... енгізу
мүмкіндігінің (А.3 – сурет), басқа қабылдаулардың (А.4 және А.5 ... ... ... ... ... ... ... материалдардың және дайын өнімнің есебі ... ... ПБУ 5/01 ... - ... ... және оны қолданылудың әдістемелік нұсқауларына сәйкес жасалған
[19].
Тауарлық – материалды ... ... ... ... шаруашылық құбылыстары ақпараттық базаға сәйкесінше құжаттардың
енгізілуі арқылы тіркеледі. Осы жағдайда бухгалтерлік проводкалар автоматы
түрде ... ... ... ... ақпараттар
негізінде толтырылады.
«Тауарлардың және қызметтің түсуі» құжатын енгізу арқылы ТМҚ түсуін
тіркеген кезде, түсіп жатқан ТМҚ ... ... ... ... ... саналады. (А.7 – суреті). Сонымен ... ... ... ... ... ... номенклатуралы
позиция үшін конфигурация автоматты түрде ... ... ... ... ... және кейбір басқа мәліметтерді бере ... ... ... ... ... ... қалыптастыру үшін
қолданылады.
Проводка «Тауарлар» қосымшасының кестелік ... ... ... ... Проводканың дебетінің субконты (аналитикалық есеп
объектісі) ... ... ... ... ... бір атаулы бағанасының элементі көрсетіледі. Осылайша, ТМҚ
аналитикалық есебі «Номенклатура» анықтамалығының ... ... ... ...... құндылықтардың атаулары және
басқада реквизиттары сақталған.
ТМҚ есебінің бухгалтерлік шоттарын орын ... ... ... ... ... ... базада сақталатын арнайы тізімнен сәйкес
келетін жазуды таңдайды. Есептің шотын көрсету үшін орын ... ... ... ... ұқсас сізімнен сәйкес келетін жазу таңдалады. Орны
бойынша принципін қолданылуға сәйкес ТМҚ ... ... ... мен ... арасында жұмысты келесі түрде бөлуге
болады.Бухгалтерлер жалпы әдістемелік басқаруды жүргізеді, ТМҚ ... ... ... шоттарды қою үшін қолданылатын тізімдерді
толтырады және бақылау ... ... де ... алдын – ала
толтырылған тізімдер бар). Ал, ТМҚ ... ... ... ...... қаруландыру бөлімшелерінің
қызметшілері, өндірістік бөлімшелер және т.б) құжаттарды енгізеді, оларды
ТМҚ ... және ... ... ... одан ... ... ережеге сай автоматты түрде қалыптасады [20].
Бухгалтерлік есептердің ... ТМҚ ... ... ... ... ... ... аналитикалық есепті жүргізуді
қамтамасыз ...... ... ... «Номенклатура»
анықтамалығының элементі) және сақталу орны бойынша (қоймалар). Бұл ... және бар ... ... бухгалтерлік есепті қалыптастыруға
көмектеседі.
Контрагентпен келісім туралы мәліметтер және есеп – ... ... ... ... ... Және де бір контрагентпен әр түрлі
есептесу шарты бар ... ... ... ... ... есеп–қисап құжатын тіркеген кезде
бухгалтерлік проводкалар ... ... ... Осы кезде
аналитикалық есеп мақсатында контрагент проводкада дебет немесе кредиттің
субконты ... ... ... ... ... ретінде –
келісім, ал үшіншісі ретінде – есеп – ... ... ... алады.
Конфигурация аналитикалық есепті есеп – қисап құжаттары ... оның ... жоқ ... де ... алады, яғни келісімнің
сипаттамасында келісім бойынша есеп – қисап ... ... ... ... үшін есеп – ... ... шартты бірліктермен таңдалса, онда
курстық айырмашылықтарды ... үшін ... бір есеп – ... ... ... осы ... есеп - ... құжат ақпараттық базадан автоматты
түрде ФИФО әдісі бойынша алынады [18].
Құжаттардың соммасы ... ... ... ... және ... өйткені бұл соммалар бухгалтерлік есепте бөлек көрсетілуі керек.
Конфигурация бухгалтерлік есепте өндірістік процестердің толығымен
көрсетілуіне есептелген. Ақпараттық базада ... ... ... – жауапты адамдар арысандағы материалдық құндылықтардың орын
ауыстырулары, дайын өнімді және жартылай ... ... ... ... ... ... ... кеткен тура және жанама
шығындар тіркеледі. Бухгалтерлік есепте ... ... ... ... құжаттарды енгізуі керек және әрбір құжат бойынша
автоматты ... ... ... ... Проводкалардың
реквизиттары құжаттардың реквизиттарына тәуелді көрсетіледі.
Құжаттардың ... ... ... қалыптасқан
проводкаларды проводкаларға арналған журналдың фрагментін ашып қарауға
болады.
Өндірісте материалдардың берілуі «Талаптар – ... ... ... мүмкін, ал жұмыс күнінің ұзақтығында шығарылған ... «Бір ... ... есебі» құжатында тіркелуі мүмкін (А.11 –
суреті).
Шығарылған ... ... ... ... ... үшін ... ... өндірістің инвентаризациясы жүргізіледі, оның ... ... ... ... құжаттың атауы да ... ... ... ... (А.12 – ... Бұл ... бухгалтерлік есеп бойынша инвентаризациялау мәліметтеріне
сәйкес және ай ... ... өнім ... ... ... ... материалдар туралы мәліметтерді түзетіп, аяқталмаған өндірістің
қалдықтарын әкеледі.
Егер кәсіпорынның құрамына бірнеше өндірістік бөлімшелер ... онда «Бір ... ... ... және ... ... ... әрбір өндірістік бөлімше үшін енгізіледі.
Негізгі құралдардың есебі бойынша ...... ... ... ... ...... құжаттармен
тіркеледі. Алдын – ала қарастырылғандай, ... ... ... әр
түрлі әдіспен пайда болуы мүмкін: оны сатып алу және ары ... ... ... ... нәтижесінде, монтаж нәтижесінде.
Негізгі құралдарды сатып алу және монтажбен байланысты қосымша ... ... ... ... ... алу кезінде ақпараттық базаға бухгалтерлік
есеп үшін және ары ... ... ... үшін ... ... Көп жағдайда бухгалтерлердің негізгі құралдардың есебін жүргізу
мәселесі осымен аяқталады. Негізгі құралдар туралы ... ... ... ... ... (А.13 – ... ... тіркеу кезінде оның бухгалтерлік есеп шоты және
амортизация шоты, материалды ... адам ... ... ... және
негізгі құралды тиімді пайдалану мерзімі көрсетіледі. Амортизацяның күрделі
әдістері қолданыла алады, ай бойына есептелген амортизайия ... ... ... ... ... ... объектілері арасында бөлуге
болады. ... ... ... ... ... ... есептеу графигін көрсетуге болады.
Негізгі құралдардың түсуімен, шығарылуымен және қалыпының
өзгеруімен байланысты шаруашылық операциялар сәйкес ... ... емес ... ...... жұмыстарының (НИОКР) соңғы нәтижесі
ретінде тіркелуі мүмкін, осы кезде осы жұмысқа кеткен шығындар объектінің
бастапқы құнында ... ... ... емес ... есепке алған
кезде, ақпараттық базаға материалды емес ... ... ... ... үшін және ары ... ... есептеу үшін қажетті
ақпараттар енгізіледі (А.14 – суреті).
Еңбек ақыны және онымен ... ... ... ... ... ... ... жолымен еңбек ақыны есептеудің
автоматтандырылған механизмінің көмегімен орындалады.
Еңбек ақыны есептеу функционалы автономдылықтың ... ... ... ... және ... да ... ақпараттың детальдану дәрежесі
талап етілмеуімен байланысты. Сондықтан, конфигурацияның басқа жүйелеріне
қарағанда ... ... ... ... ... ... қалыптастырмайды, және сәйкесінше бухгалтерлік есепте
көрінбейді. ... ... ... санаулары мен ұстап қалулары
туралы мәліметтердің көрінуі үшін «Регламенттелген ... ... ... құжаты арналған (А.15 – суреті).
Ұйымның қызметкерлеріне еңбек ... ... және ... ... ... ... ... ақшалы құралдарды басқару жүйесінің
ақшалы құжаттарымен тіркеледі. Бұл жүйенің құжаттары үшін ... ... ... ... – ала ... бұл бухгалтерлік
есепте жұмысшылар мен бюджет алдындағы қарыздарының өтелгені туралы
көріністі қамтамасыз ... Және де ... ... ... ... есептесудің қалпының өзгерісінің дұрыс көрінісі үшін ... ... ... ... ақы» жүйесінің құжаттарына сілтеме
жасалуы керек, өйткені осы құжатта жұмысшылардың саны және ... ... ақы ... ... (А.16 – ... ақпараттық базада бірнеше ұймның ... ... ... ... ... кішігірім ... ... ... ... ... ... бар ... қолданыста бола алады.
4.1.1.2 1С – 1С:7.7 ӨКБ шешімі
«Өндірістік кәсіпорынды басқару» (ӨКБ) ... ... ... ...... есепке ала отырып, қаржылы ... ... ... үшін бір ақпараттық кеңістік құрады.
Сонымен қатар бұл шешім сақталатын мәліметтерге ... ... ... (Б.1 – ... ... ... ... жеке жүйелерге бөлінеді: ақшалаай құралдарды басқару жүйесі,
бухгалтерлік есеп жүйесі және т.б. (Б.2 – ... ... ... ... ... ол осы ... ... түсінуді оңайлатады.
Қолданушылардың ағымдағы ... ... ... ... ... ... ... ақпараттық база,
холдингке кіретін барлық ұйымдарды өзіне кірістіре ... Бұл ... ... ... ... ... ... әр түрлі
ұйымдармен қайта қолданылу ... ... ... ... ... және регламенттелген (бухгалтерлік және ... ... ... ... есептілік ұйымдар бойынша жеке жасалады
[13].
Шаруашылық операцияны орындау факті бір рет ... ... ... есептерде көрінісін табады. Ақпаратты
қайталап енгізу қажеттілігі жоқ. Шаруашылық операцияны ... ... ... табылады, және де жұмысты тездету үшін «орын бойынша» мәліметтерді
қою механизмі қолданылады, жаңа ... ... ... ... ... ... әр ... есептердің мәліметтерінің
қатынасының келесідей принциптері қабылданған:
• басқарушылық, бухгалтерлік және салықтық мәліметтердің тәуелсіздігі;
... ... және ... ... ... бухгалтерлік және ... ... ... және ... ... және ... ... бойынша регламенттелген (бухгалтерлік және салықтық) есеп
ұлттық валютамен жүргізіледі, бірақ басқарушылық есеп үшін ол ... ... ... ... таңдалып алына алады. Әр түрлі ұйымда бір ... ... ... әр ... ... ... бір ұйымда – салық
салудың жалпы жүйесі, ...... ... ... ... әртүрлі саясаты да қолданыла алады. Одан ... ... жеке ... ... салудың жүйесі уақытша ... ... ... ... ... және ... есептерді қосымша қаржылық
есептіліктің халықаралық стандарты ... ... ... ... ... ... мақсатында ҚЕХС бойынша есеп оперативті емес ... ... ... ... қолданылу арқылы жүргізіледі.
Жоспарлау және басқарушылық есеп ... ... ... ережелер бойынша құрылады және кәсіпорындағы бизнес –
процестерді басқару үшін ... ... алу үшін ... ... ... ... жүйесі келесі сұрақтарға жауап беруі тиіс:
1. Не өндіріледі?
2. Бізге оны қанша уақыт өндіруге болады?
3. Біз не көреміз?
4. Бізге не қажет?
5. Біз не ... ... ... ... ... процесін бірнеше кезеңдерге бөлу керек
болады. Әрбір кезең уақыт горизонтымен, мерзімділікпен, бөлшектеудің анық
дәрежесімен сипатталады.
Ұзақ ... ... үшін ... ... жыл ... ... ... Құрылымдық сұлбаны анықтау
Жаңа бөлімді жасау кезінде дұрыс ... ... ... ... ... ... ... функциялардың орындалмауына және тиімсіз
болуға әкеледі. Дұрыс жобаланып жасалған кестелер тек ағымдағы мәліметті
шешуге ғана ... оны ары ... ... ... мүмкіндік береді.
Мәліметтер базасына әрқашанда көлемінің үлкен болуы ... ... ... ... бар. Жаңа ... ... базасына жаңа сұраныс
тудырады, бұл оның элементтерінің ... ... ... Сондықтан мәліметтерді ұйымдастырудың қарапайым және анық
сұлбаларын ойланып жасау қажет.
Мәліметтер құрылымын жасау үшін көпмүше ... ... ... ... ... ... моделін қолданамыз.
Алдымен, осы теорияның негізінде байланыстырушы жолдар ... ... ... ... ... ... Бірінші қалыпты кесте формасын
алу үшін жолдар мен олардың мәндері қайталанбауы тиіс.
Берілген кестеден екіншісіне сұраныс жасау үшін олар да ... ... ... ... өзінің кілтінен немесе жазбасын анықтайтын кілттен
тұруы тиіс.
Реляциондық моделдің негізгі артықшылығы бұл оған жаңа ... қосу ... ... ... ... ... ... басқару жүйесі мәліметтерді анықтау процесін толық
бақылауға, ... және ... ... ... ... МББЖ сонымен
қатар, көп кестелерге сақталатын ақпарат көлемін өңдеуге көмектеседі. ... ... ... мәліметтер базасында жүргізіледі.
1С Кәсіпорын – командалардың интеративті ... ... ... Ол ... ... ... болатын жеке
программаларды құруға мүмкіндік береді.
1С КӘСІПОРЫН -да үлкен көлемді ақпаратпен ... ... ... ... және анықтаудың қажетті жабдықтары қарастырылған.
1С КӘСІПОРЫН -дағы ... ... ... ... ... ... және ... жатады. Әдетте мәліметтер базасы термині
мәліметтер сақталатын файлдарға ғана жатады. ...... ... ... тізімі берілген:
• Кесте – мәліметтерді сақтау және анықтау үшін қолданылатын нысан. ... ... бір ... ... ... ... тұрады. Кестенің
жолақтары (бағаналары) субъекттер жөніндегі әртүрлі сипаттамаларды, ... ... (жол) ... бір ... ... ... ... үшін
қолданылады.
• Сұрау – қолданушыға бір немесе ... ... ... ... ... ... нысан. Сұрауды анықтау үшін есептер конструкторын
немесе SQL инструкциясын жазуға болады. Сұраулардың ... ... ... ... ... ... жазуға кесте құруға болады.
• Форма – мәліметтерді енгізуге, оларды экранға шығаруға немесе қосымшаның
жұмысын басқаруға қажетті нысан.
• Есеп – таңдалған ... ... ... ... және
баспаға шығаруға қажетті нысан.
• Класс – мәліметтерді, жағдайларды өңдуге арналған тәсілдер, жағдайлар
қасиеттер құрамынан ... ... ... ... ... ... алуға болады. VFR
мәлiметтердiң әртүрлi типтерiн (текст, сандық шамалар, дата, уақыт, ақшалық
белгi, суреттер, ... ... ... ... ... ... бередi.
4.4 Логикалық сұлбаны құрастыру
Кез-келген АЖО-н толық жобалау бiрқатар кезеңдер мен ... ... ... ... ... ... Осы жоба ... ортасында жасалынды:
1 Логикалық жобалау
1.1 АЖО құру мақсатын анықтау
1.2 Кестелер мен ... ... ... ... ... арасындағы байланысты анықтау
2 Кестелер құру
2.1 Кестелер тұрғызу
2.2 Кесте жолдары үшiн мәлiметтер типерiн белгiлеу
2.3 ... ... ... пен ... ... ... жобалу
Логикалық жобалау туралы айтқанды, келесi терминдердi: «маңыздылық,
байланыс, атрибут» қолданады. Маңыздылық- ... деп ... бiр ... ... ... ... ... жеке дара және бiр-бiрiнен
ерекшеленедi.
Атрибут- ... ... ... ... мен ... ... ... логикалық қатынас.
4.5.1 АЖО-н құру мақсаттарын анықтау
Бiрiншi кезеңде АЖО-ның құру ... ... ... және
ақпаратты анықтау қажет.
Мәлiметтер базасы онымен жұмыс iстеушiнiң барлық талаптарына жауап
беруi тиiс.
Жобалаудың ең ... ... бiрi- ... ... ... базасының кестелерiн жасау болып табылады.
Осы кезеңде алдымен келесi принциптерге сүйену қажет:
▪ Кестелердегi ақпарат қайталанбауы тиiс
... ... бiр ғана ... ... тұруы тиiс, бұл жағдайда
мәлiметтердi, егер әр түрлi кестелерде орналасса, оңайға соғады.
Кiтапханалық каталогтарды өңдеуге арналған осы ... ... ... және ... ... ... ... базасында қажеттi анықтамалар сақталуы тиiс. Олардың көбi жеке
каталогтық карталарда ... (3.1 ... ... ... ... оқулыққа сұраныстарын талдау каталогтық картаның
келесi ... ... ... ... ... К. Руководство по реляционной СУБД DB2 / пер. с |
| ... И ... ... –М.: ... и |
| ... 1988. – 320 с.: ил. |
| |ISBN ... |
| ... американского специалиста в области реляционных |
| |баз данных К.Дейта, автора популярной в СССР ... ... в ... баз ... ... ... |
| |руководство по СУБД фирмы IBM DB2. Для ... по |
| ... ... ... систем и |
| ... ... |
| |ББК 32.973 ... 4.1 ... ... ... (әрбiр басылым авторының фамилиясы, аты-жөнi);
▪ Атауы;
▪ Том номерi;
▪ Басылым түрi ... ... ... Құрастырушы (басылымның әрбiр құрастырушысының аты-жөндерi);
▪ Кiмнiң редакциясынан (аты-жөндерi);
▪ Басылымның қайта басылуы;
▪ Баспа;
▪ Шыққан жерi (қаласы);
▪ Шыққан жылы;
▪ Басыламдық аннотация ... ... ... ... ... таңба.
Кiтапханалық шифр және авторлық таңба басылымдарды сөрелерде мазмұны
және алфавитi бойынша ... үшiн, ... ... ... ... ... (КБК) басылымдарды
(оқулықтарды) мазмұнына сәйкес бiлiм салаларына қарай бөледi. Онда сатылы
құрылымды сандық-әрiптiк ... ... ... ... ... ... тарихы; 2. Жаратылыстану ғылымдары; 3. ... ... 4. ... және ... ... 5. Денсаулық сақтау;
6/8. Қоғамдық және ... ... 9. ... ... ... Журналдар.) iшкi кластарға (подкласс) және ... ... ... ... ... ... ... ... ... техникасы ... ... ... ... және құрылғылар ... ... ... ... ... ... және ... ... ... ... ... ... ... және сөрелердi
белгiлеу үшiн, сонымен қатар каталогтар мен статистикалық отчеттарды
құрастыру үшiн қолданылады.
Автордың ... ... және ... ... бiрiншi
әрпiнен және саннан тұратын авторлық таңба кiтаптардың сөрелерде алфавиттiк
қатарда орналасуын ... ... ... ... орындарын сипаттауға болатын нысандар мен атрибуттарға ... ... ... номер);
• Түсу уақыты;
• Оқырман фамилиясы;
• Оқырман аты;
• Оқырманның әкесiнiң аты;
• Адресi;
• Үй телефоны;
... ... беру ... ... қайтарған мерзiмi.
Жобаланатын мәлiметтер базасының әрбiр кестесi жеке тақырыптағы, ал
кестенiң әрбiр жолы ... ... ... ... ... тиiс. ... ... келесiлердi ескеру қажет:
• Әрбiр жол кесте тақырыбымен ... ... ... ... есептеулер нәтижелерiн жазуға кеңес берiлмейдi;
• Кестеде барлық қажеттi ақпарат болуы тиiс;
• Ақпаратты аздаған логикалық бөлiктерге бөлу қажет;
Келесi кестелер мен атрибуттарды ... ... ... ... ... ... үлес қосқан адамдар (авторлар, ... ... ... сақталады.
2. Басылым түрлерi (Басылым_түрi, Олардың_атаулары)- мұнда ... ... ... ... сақталады. Олардың_атаулары атрибуты
нақты санды тип болып келедi, оның мәнi жаңа кiтап қосылғанда бiрге ... ... ... кiтапханалық_код, Бөлiм_коды)- мұнда бөлiмдердiң
атаулары, кiтапханалық-библиографиялық ... ... ... ... ... сақталады.
4. Басылым (Басылым_коды, Бөлiм_коды, Авторлық_таңба, Баспахана_коды,
Аннотация)- мұнда осы бөлiмге кiретiн ... ... ... ... Осы ... де ... ... тип беремiз, оның мәнi жаңа кiтап
қосылғанда ... ... ... Дана ... ... ... мұнда нақты бiр экземпляр
жөнiнде ақпарат сақталады, мысалы, инвентарлы номер, алу уақыты.
6. Топ (Топ_коды, Топ_атауы)- ... ... ... ... ... ... Осы ... де нақты типтi сандар берiледi, жаңа
оқырман қосылғанда оның мәнi бiрге ... ... ... ... ... ... ... Қала_коды, Көше_коды, Пәтер_коды, Телефон_коды,
Туған_күнi, Тiркеу_уақыты, Түсiнiктеме)- мұнда оқырман туралы жалпы мәлiмет
сақталады.
8. Авторлар ... ... бұл ... Құрастырғыш және
Басылым деп аталатын кестелер ... ... ... ... ... ... бұл ... Құрастырғыш
және Басылым деп аталатын кестелер негiзi болып табылады.
10. Редакторлар (Құрастырыш_коды, Басылым_коды)- бұл кесте Құрастырғыш ... деп ... ... ... болып табылады.
11. Қолға беру (Дана_номерi, Оқырман_номерi, Беру_уақыты, Өткiзу_уақыты)-
бұл кесте Дана және Оқырман кестелерiнiң негiзi болып табылады.
12. ... ... ... ... ... фамилиялары туралы
ақпарат сақталады. Фамилия_коды атрибуты жаңа фамилия ... ... ... ... ... ... ... оқырман аттары сақталады. Есiм_коды
атрибуты жаңа ат қосылғанда бiрге артып отырады.
14. ... ... ... ... ... тұратын қалалар атаулары
сақталады.
15. Қалалар ... ... ... тұратын қалалар сақталады.
4.5.6 Кестелер арасындағы байланыстарды анықтау
Кестелер бойынша мәлiметтер таратқан соң және жолдарды ... ... ... ... ... ... сұлбасын құрастыру қажет.
Ол үшiн алдымен кiлттiк жазбаларды және ... ... ... ... ... ... мәлiметтердi тиiмдi байланыстыруға
мүмкiндiк бередi. Кестелердi құрғанда әрбiр жаңа кестеге жол мен ... жол ... ... жолдар сыртқы кiлттер деп
аталады.
Осы мәлiметтер базасындағы Бөлiм кестесiн ... ... ... осы ... Бөлiм_коды деп аталатын бiрiншi кiлтi ... ... ... ... кiлт ... ... қолданылады. Оның
көмегiмен Авторлар, Құрастырғыштар, Редакторлар кестелерiмен байланыс
жүргiзiледi. Өз ... ... ... ... атты
бiрiншi кiлт бар.
4.6 Индекстердi және кесте аралық байланыстарды құру
Кестелердегi ... көп ... ... ... iздестiру
тиiмдiлiгi үшiн индекстер саны көп болуы қажет. ... екi ... iшкi ... ... ... бойынша индекстер құру үшiн ... Primary ... ... қою ... ... кiлттер үшiн Regular типi
қолданылады.
Қажеттi кестелер мен индекстердi ... ... ... ... ... ... мәлiметтер базасындағы барлық кестелер «бiреуi
көбiне» қатысты байланысады. естелер арасында байланыс орнату үшiн ... ... ... ... қосу ... ... дайындау және таратау
5.1 Алгоритмдi жасау
Мәлiметтер базасының негiзгi қызметi қолданушыға қажеттi ақпаратты
беру сонымен қатар қолданушыға жаңа ... ... ... базасын
толықтыру және де мәлiметтер базсындағы сақталатын компоненттердi өзгерту
мүмкiндiгi берiледi.
Осы аталған ... ... мен ... ... ... ... ... циклiн анықтайды. 4.1 суретте көрсетiлген МБ-
ның ақпараттық ағынының ... ... ... ... әрекеттердi орындауға арналған бiрқатар тапсырмалар түседi.
Ақпаратты өңдеудiң технологиялық сұлбасын тарататын жалпыланған
алгоритмi келесi әрекеттерден тұрады:
1. ... ... ... таңдау
2. Формалар жолдарын толтыру
3. Бейне бақылаушы құрылғыда ақпаратты кескiндеу
4. Алынған мәндердiң нақты көшiрмесi ... ... ... мәлiметтердi
енгiзу.
5. Мәлiметтердi анализдеу
6. Диагностикалық хабарламалар беру
7. Сәйкес сұранысқа мәлiметтер беру
8. ... және ... ... ... ... Ақпаратты iздеуге арналған кестелер тiзiмiн тарату
10. Параметрлерге және таңдау шарттарына сәйкес кестелерден ақпаратты
iздеу
11. Егер берiлген параметрлерге және ... ... ... ... онда ... ... ... және 1 пунктке көшедi.
Ал егер қажеттi ақпарат ... 9 ... ... Оны ... ... ... келесi 13 пунктке көшедi.
13. МБ-ның жұмысын аяқтау қажеттiгiн анықтау. Егер ия ... ... жоқ ... 1 ... ... ... ... соңы.
Осы алгоритм 4.2 суреттегi алгоритммен көрсетiлген. АЖО келесi режимдерде
қызмет етедi:
• АЖО-ның ... ... ... ... ... ... ақпаратты көру;
АЖО-ның МБ-ғы ақпаратты түзету, шығыстық кодтарды тарату
Сурет 5.1 АЖО-ң ақпараттық ағындарының сұлбасы
Қолданушы жұмыс режимдерiн программалық модуль қосылғаннан кейiн ... ... ... ... сұлба 5.2 суреттегiдей болады.
Сурет 5.2 Ақпаратты ... ... ... ... ... ... ... құрылымдық-функционалдық сұлбасы көрсетілген.
Сурет 5.3 АЖО-ң құрылымдық-функционалдық сұлбасы
Мысал үшiн басқарушы модульдiң таралу алгоритмiнiң блок-схемасын
қарастырайық.
Сурет 5.4 Басқарушы модульдiң таралу алгоритмiнiң ... ... ...... ... ... модульдері
АЖО функционалды түрде келесi модульдерден тұрады:
• Қолданушыны және оның құқын анықтауға арналған идентификациялау ... ... Қор ... бойынша әртүрлi отчеттар алуға, оларды ... қор ... ... ... туралы әртүрлi отчеттар алуға, оларды көруге арналған
картотекалардың модульдерi;
• МБ-ң ... және ... ... қажеттi модульдер;
• Администратор модулi.
Функционалды модулге кiру жүйелiк менюмен жүргiзiледi.
Меню жүйесi 5.5 суретте көрсетілген.
Сурет 5.5 Жүйелік меню ... ... ... ... ... үшін ... кітаптар бере алатын,
оқырмандардың қарыздарын қадағалап отыратын және ... ... ... ... есеп жасай алатын ... ... ... құру ... ... ... анықтамалығынан тұрады. Әрбір
кітаптың ерекше кітапханалық номері (код) бар. ... ... бір ... кітаптардың бірнеше экземплярлары бар.
Оқырман кітапхананың негізгі құраушы бөлігі ... ... ... ... атты ... болуы тиіс. Әрбір оқырманға
номері бар оқырман билеті беріледі. Программада келесі жағдайлар белгіленуі
тиіс.
• Оқырманға ... ... ... ... ... ... ұзарту
• Оқырман алған кітабын кітапханаға айтқан мерзімде қайтару қажет
• Оқырман жоғалтқан ... ... ... ... ... ... үшін сәйкес құжат қарастыру қажет
Кітапхананың жұмыс ережесі келесідей:
• Оқырман кітапханадан кітаптардың белгілі бір санын ғана ала ... ... ... ... ... бір айға алады, немесе өзі қай ... ... ... ... мерзімге алуына болады.
• Оқырман кітаптың мерзімін ұзарта алады.
• Кітапты қайтару уакыты асып кеткен ... ... ... алады.
• Егер ескертулер саны шектен асып кетсе, ол ... ... 1 айға ... ... алған кітапты жоғалтқан жағдайда да 1 айға құқықтан
айрылады.
Құрылатын программада ... ... ... ... ... ... құрастыру мүмкіндігі болуы тиіс. Сонымен
қатар, программада әрбір жеке ... ... ... және ... ... ... қажет екендігі жөнінде ақпарат болуы тиіс.
5.3.1 Конфигурациялау нысандары
Конфигурацияда келесі нысандарды құру талап етіледі:
|Нысандар типтері|Нысандар ... ... |
| ... |
| ... |
| ... ... ... |
| ... ... спр. ... |
| ... |
| ... |
| ... ... |СтатусКниги (значения: Свободна, Выдана, Списана) |
| ... ... Да, Нет) ... ... |
| ... |
| ... |
| ... ... ... ... | ... ... |
| ... ... ... түсініктеме.
Анықтамалық "Шығармалар" (элемент формасы)
Шығармалар анықтамалығының элементінің экрандық формасы келесі түрде
болады:
Сурет 5.6 Шығармалар анықтамалығының экрандық ... ... ... ... ... ... ... берілген:
Процедура ВыбратьАвторов()
Конт = 0;
ОткрытьПодбор("Справочник.Авторы","ФормаСписка",Конт,1);
КонецПроцедуры
Процедура ОбработкаПодбора(ВыбрЭлемент,КонтФормы)
Если СокрЛП(Авторы) "" Тогда
Авторы = ... = ... + ", " ... ... (тізім формасы):
«Кітаптар» анықтамалығының элементінің экрандық формасы келесі түрде
болады:
Сурет 5.7 «Кітаптар» анықтамалығының ... ... ... ... ... құжаты
"Кітапты беру" құжатының элементінің экрандық формасы келсі суретте
көрсетілген:
Сурет 5.8 ... ... ... ... беру» құжатының формасын құрастырудың программалық модулі келесі
листингте берілген:
Процедура УстКниги()
Если Число(СрокВозврата)=0 Тогда
СрокВозврата = ДатаДок + ... ... ... = ... ПриЗаписи()
Если Читатель.Выбран()=0 Тогда
Предупреждение("Не указан читатель!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Читатель.Блокирован.Получить(ДатаДок) = ... ... не ... ... ... Возврат;
КонецЕсли;
Если КоличествоСтрок()=0 Тогда
Предупреждение("Не указано ни одной книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Произведение.Выбран()=0 Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " ... ... ... Книга.Выбран()=0 Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " не
указана ... ... ... ... Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " книга
не является Свободной!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Число(СрокВозврата)=0 Тогда
Предупреждение("В строке " + ... + " ... срок ... ... на ... книг у ... = ... = создатьОбъект("Справочник.Книги");
СпрКниги.ВыбратьЭлементыПоРеквизиту("Читатель",Читатель,0,0);
Пока СпрКниги.ПолучитьЭлемент()=1 Цикл
КолвоКнигНаРуках = КолвоКнигНаРуках + 1;
КонецЦикла;
Если ... + ... ... Тогда
Предупреждение("У читателя будет слишком много книг ... ... ... ... өткізудің программалық модулі:
// ********************
//
Процедура ОбработкаПроведения()
СпрКниги = создатьОбъект("Справочник.Книги");
ВыбратьСтроки();
Пока ... ... = ... = ... = ... = СрокВозврата;
СпрКниги.Записать();
КонецЦикла;
КонецПроцедуры
5.3.4 "Кітаптың уакытын ұзарту" құжаты
"Кітаптың уакытын ұзарту" құжатының элементінің экрандық формасы
келсі суретте көрсетілген:
Сурет 5.9 ... ... ... ... ... экрандық формасы
"Кітаптың уакытын ұзарту" ... ... ... ... ... келесі листингте берілген:
Процедура ПриЗаписи()
Если Читатель.Выбран()=0 Тогда
Предупреждение("Не указан читатель!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Читатель.Блокирован.Получить(ДатаДок) = ... ... не ... ... книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если КоличествоСтрок()=0 Тогда
Предупреждение("Не указано ни одной книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
УказанХотяБыОдинНовыйСрокВозврата = 0;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Произведение.Выбран()=0 Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " ... ... ... ... ... ... " + Строка(НомерСтроки) + " не
указана книга!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Книга.Статус Перечисление.СтатусКниги.Выдана ... ... " + ... + " ... является Выданной!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Число(НовыйСрокВозврата)0 Тогда
УказанХотяБыОдинНовыйСрокВозврата = 1;
КонецЕсли;
КонецЦикла;
Если УказанХотяБыОдинНовыйСрокВозврата = 0 ... ... ни одна ... ... быть ... бы один новый срок возврата!");
СтатусВозврата(0); Возврат;
КонецЕсли;
КонецПроцедуры
Процедура УстЧитатель()
УдалитьСтроки();
СпрКниги = создатьОбъект("Справочник.Книги");
СпрКниги.ВыбратьЭлементыПоРеквизиту("Читатель",Читатель,0,0);
Пока СпрКниги.ПолучитьЭлемент()=1 Цикл
НоваяСтрока();
Книга = СпрКниги.ТекущийЭлемент();
Произведение = СпрКниги.Владелец;
СрокВозврата = СпрКниги.СрокВозврата;
КонецЦикла;
КонецПроцедуры
Процедура ПриВводеСтроки()
СтатусВозврата(0);
КонецПроцедуры
Процедура ПриУдаленииСтроки()
СтатусВозврата(0);
КонецПроцедуры
«Кітаптың уакытын ... ... ... ... ... ... ... = создатьОбъект("Справочник.Книги");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Число(НовыйСрокВозврата)0 Тогда
СпрКниги.НайтиЭлемент(Книга);
СпрКниги.СрокВозврата = НовыйСрокВозврата;
СпрКниги.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры
5.3.5 «Кітапты қайтару» құжаты
"Кітапты қайтару" ... ... ... ... ... ... 5.10 ... қайтару" құжатының элементінің экрандық формасы
"Кітапты қайтару" құжатының ... ... ... ... ... берілген:
Процедура УстКниги()
Если Произведение.Выбран()=0 Тогда
Произведение = Книга.Владелец;
КонецЕсли;
КонецПроцедуры
Процедура ПриЗаписи()
Если Читатель.Выбран()=0 Тогда
Предупреждение("Не указан читатель!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если КоличествоСтрок()=0 Тогда
Предупреждение("Не указано ни одной книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 ... ... ... строке " + Строка(НомерСтроки) + " не
указано произведение!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Книга.Выбран()=0 Тогда
Предупреждение("В строке " + ... + " ... ... ... Книга.Статус Перечисление.СтатусКниги.Выдана Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " книга
не является Выданной!");
СтатусВозврата(0); Возврат;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
«Кітапты қайтару» ... ... ... ... ********************
//
Процедура ОбработкаПроведения()
СпрКниги = создатьОбъект("Справочник.Книги");
СпрЧитатели = СоздатьОбъект("Справочник.Читатели");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
СпрКниги.НайтиЭлемент(Книга);
Если СпрКниги.СрокВозврата < ДатаДок Тогда
СпрЧитатели.НайтиЭлемент(Читатель);
СпрЧитатели.КоличествоПредупреждений ... + ... ... ... ... ... ... ... = ... = ... = 0;
СпрКниги.СрокВозврата = 0;
СпрКниги.Записать();
КонецЦикла;
КонецПроцедуры
5.3.6 "Кітапты жоғалту" құжаты
"Кітапты жоғалту" ... ... ... ... келесі
суретте көрсетілген:
Сурет 5.11 "Кітапты жоғалту" құжатының элементінің экрандық формасы
"Кітапты ... ... ... ... ... ... ... листингте берілген:
Процедура УстКниги()
Если Произведение.Выбран()=0 Тогда
Произведение = Книга.Владелец;
КонецЕсли;
КонецПроцедуры
Процедура ... ... ... ... читатель!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если КоличествоСтрок()=0 Тогда
Предупреждение("Не указано ни одной ... ... ... ... ... ... ... " + Строка(НомерСтроки) + " не
указано произведение!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Книга.Выбран()=0 Тогда
Предупреждение("В строке " + ... + " ... ... Возврат;
КонецЕсли;
Если Книга.Статус Перечисление.СтатусКниги.Выдана Тогда
Предупреждение("В строке " + ... + " ... ... ... Возврат;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
«Кітапты жоғалту» құжатын өткізудің программалық модулі:
Процедура ОбработкаПроведения()
СпрКниги = создатьОбъект("Справочник.Книги");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
СпрКниги.НайтиЭлемент(Книга);
СпрКниги.Статус = Перечисление.СтатусКниги.Списана;
СпрКниги.Читатель = 0;
СпрКниги.ДатаВыдачи = ... = ... ... ... ... ... ... ... түбіртек" есебінің элементінің экрандық формасы келесі
суретте көрсетілген:
Сурет 5.12 "Кітапханалық түбіртек" есебінің элементінің экрандық ... ... ... ... ... модулі келесі
листингте берілген:
//*******************************************
Процедура Сформировать()
тз = создатьОбъект("ТаблицаЗначений");
тз.НоваяКолонка("Дата");
тз.НоваяКолонка("ТипОперации");
тз.НоваяКолонка("Читатель");
тз.НоваяКолонка("Книга");
тз.НоваяКолонка("СрокВозврата");
//---------------------
//Документы ВыдачаКниги
//---------------------
Запрос = создатьОбъект("Запрос");
ТекстЗапроса = "
|Период С НачДата По КонДата;
|ОбрабатыватьДокументы Проведенные;
|Док = ... = ... = ... = ... ... (Читатель в ВыбрЧитатель);
|Условие (Книга в ВыбрКнига);
|";
Если Запрос.Выполнить(ТекстЗапроса)=0 ... ... ... = ... = ... = ... = Запрос.Читатель;
тз.Книга = Запрос.Книга;
тз.СрокВозврата = Запрос.СрокВозврата;
КонецЦикла;
//---------------------
//Документы ПродлениеКниги
//---------------------
Запрос = создатьОбъект("Запрос");
ТекстЗапроса = "
|Период С ... По ... ... = ... = Документ.ПродлениеКниги.Читатель;
|Книга = Документ.ПродлениеКниги.Книга;
|НовыйСрокВозврата = Документ.ПродлениеКниги.НовыйСрокВозврата;
|Группировка Книга;
|Условие (Читатель в ВыбрЧитатель);
|Условие (Книга в ВыбрКнига);
|";
Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
Возврат;
КонецЕсли;
Пока Запрос.Группировка(1)=1 Цикл
Док = Запрос.Док;
тз.НоваяСтрока();
тз.Дата = ... = ... = ... = ... = Запрос.НовыйСрокВозврата;
КонецЦикла;
//---------------------
//Документы ВозвратКниги
//---------------------
Запрос = создатьОбъект("Запрос");
ТекстЗапроса = "
|Период С НачДата По КонДата;
|ОбрабатыватьДокументы Проведенные;
|Док = Документ.ВозвратКниги.ТекущийДокумент;
|Читатель = ... = ... ... ... в ВыбрЧитатель);
|Условие (Книга в ВыбрКнига);
|";
Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
Возврат;
КонецЕсли;
Пока Запрос.Группировка(1)=1 Цикл
Док = ... = ... = ... = Запрос.Читатель;
тз.Книга = Запрос.Книга;
КонецЦикла;
//---------------------
//Документы ПотеряКниги
//---------------------
Запрос = создатьОбъект("Запрос");
ТекстЗапроса = ... С ... По ... ... = Документ.ПотеряКниги.ТекущийДокумент;
|Читатель = Документ.ПотеряКниги.Читатель;
|Книга = Документ.ПотеряКниги.Книга;
|Группировка Книга;
|Условие (Читатель в ВыбрЧитатель);
|Условие (Книга в ВыбрКнига);
|";
Если Запрос.Выполнить(ТекстЗапроса)=0 Тогда
Возврат;
КонецЕсли;
Пока Запрос.Группировка(1)=1 Цикл
Док = ... = ... = ... = ... = Запрос.Книга;
КонецЦикла;
тз.Сортировать("Дата+");
Таб = создатьОбъект("Таблица");
Таб.ВывестиСекцию("Все");
Таб.Опции(0);
Таб.Показать();
КонецПроцедуры
НачДата = НачМесяца(РабочаяДата());
КонДата = КонМесяца(РабочаяДата());
5.3.9 "Оқырмандар қарыздары" есебі
"Оқырмандар қарыздары" ... ... ... ... келесі
суретте көрсетілген:
Сурет 5.13 "Оқырмандар қарыздары" есебінің элементінің экрандық формасы
Осы есеп ... ... ... кітаптары негізінде ... 5.14 ... ... ... ... ... ... программалық модулі келесі
листингте берілген:
//*******************************************
Процедура Сформировать()
Таб = создатьОбъект("Таблица");
Таб.ВывестиСекцию("Все");
Таб.Показать();
КонецПроцедуры
6 Еңбекті қорғау
Күрделі автоматтандырылған басқару жүйелерін ... ... ... ... қолданылады, оның бастапқы сатысында, өзінде бүкіл
жүйенің тиімділігін және ... ... ... ... ... қамтамасыздандыру сұрақтары пайда болады. Бұл
жобалау процесі барысында ... ... ... ... ... ... ... негізгі есебі болып адам
және машина арасындағы ... тек ... ... ... ғана ... ... ... әзірлеу және техникалық компоненттерді
утилизациялау барысында оптималдау ... ... Бұл, ... ... және оны пайдалану барысында, мәндері, логикалары және тізбектері
бойынша бір-бірімен ... ... ... және шаралар
комплексін өткізу және ... ... ... ... қауіпсіздігі
Электр қауіпсіздік ретінде, адамдарды электр тоғының, электр доғаның
және статикалық ... ... ... және ... ... ... ... және техникалық шараларды
және құралдарды айтады. Басқа қауіп-қатер көзіне қарағанда электр тоқты
арнайы ... және ... ... сондықтан оның адамға
әрекеттестігі жиі оқас болады.
Адам бойымен өтетін тоқ күшінің мәні осы кездегі адамның ... ... күш ... дене ... кедергісіне байланысты болады. Адам
жараны көбінесе 127, 220 и 380 В тоқ ... ... ал ... ... ... В тоқ ... ... себепті, айнымалы тоқтың қауіпсіз күші ретінде
біздің мемлекетте 42 В, ал ... тоқ үшін 110 В ... ... іске ... ... өтіледі. Тоқ
күштенуінің көзі ретінде күштенуі 220В-қа тең ... тоқ ... ... тоғымен тигізуді ескерту талаптарына сәйкес қажет:
0. жұмыстарды өңдіру ережелерін және техникалық іске асыру ережелерін ... ... ... ... ... тоқ ... ... істейтіндердің, жабдықтар
бөлігіне, үлкен емес тоқ күшенуінде жұмыс істеуге тағайындалған және
қорғаныс жерлеуге ... ... ... ... алып ... электр тоғымен тиісуден қорғайтын, берік жаппай немесе көп ... ... ... ... ... арнайы электрондық - есептеуіш машинаға электр коректенуін арнайы
шаңышқы ... ... ... ... ... ғимарат розеткасының
әкелу;
4. желіден алатын тоқ күшенуіне сеніп, тоқ ... ... ... ... ... ... өшуінен ғимарат желісіне кірістірілген
жабдықтарды қорғау;
5. операторға оңай тұрған металл бөлімдерін жерге қосатын қысымдарына қосу,
өткені олар ... ... ... тоқтың қауіпті күштенуінде
болуы мүмкін;
6. жерге ... ... жол ... ... ... жоқ ... ... қатар сенімді изоляцияланғын
тексеру.
6.2 Өрт қауіпсіздігі
Өрт қауіпсіздігі деп өрттен адамдарды және жеке мүліктерді қорғауға
арналған ... және ... ... жүйесін түсінеді.
Электр желісі бар бөлмелердің өрт қауіпсіздігі ГОСТ 12.1.033-81, ГОСТ
12.1.004-85-пен регламенттелінеді. ЭЕМ ... ... ... Д категориясына сәйкес келетін бөлмеде өтілуі керек
(жанбайтын заттар және ... суық ... ... өртке
тұрақтылығы СниП 2.01.02-85 [5] бойынша I ... ... ... ... ... натурал тастан жасалған, ғимараттың жабық
бөлмелерінде жанатын материалдар жоқ).
Дисплейлер конструкцияларында көшпелік кедергіні ... яғни ... да ... ... ... ... ... ЭЕМ-ні жылу көздері
немесе термошығарушылар қасына қоюға болмайды, ЭЕМ-на ... ... ... ... ... ... оның артқы және қабырғалы жақтары басқа
заттардан 0,2 метрден кем емес ... ... ... қажет. ЭЕМ-на
корпусында жылулық режимді бұзбау үшін ... ... ... ... ескерілген.. Ішкі монтаж жоғарғы дәрежелі жылу
ұстағыш сыммен орындалған.
Объектінің өрт қауіпсіздігі қамтамасыздандырылады:
7. өртті алдын алу ... ... ... ... жүйесімен;
9. ұйымдастырушылық-техникалық шаралармен.
Өртті бөлмеде алдын алу жанатын материалдардың ... ... ... ... және де тез жанатын материалдың жоқтығымен
жеткізіледі.
Ұйымдастырушылық-техникалық ... ... ... ережелеріне оқытуды ұйымдастыруды кірістіреді.
6.3 Шу деңгейлеріне және дірілдеуге талаптар
Операторға бөгеттердің тигізетін ықпалы ... және оның ... ... ... ... туады. Операторға әсер ету
көзқарасынан бөгеттер әртүрлі болады. Олардың біреуі тұрақты және ... ... ... ... ал ... кездейсоқ болады.
Компаниялардың жұмыс бөлмелерінде акустикалық шулардың негізгі көзі
ДЭЕМ-дың шуы болып табылады. Сонымен қатар ЭЕМ электромагнитті ... ... көзі ... та ... ... ... ... әсерінен туатын
электромеханикалық құралдар элементтерінің ... ... ... ... ... шу пайда ... яғни ... ... ... жиіліктердің дыбыстық диапазонындағы
ғимараттардың жабулары, қалқаларынан ... ... емес ... ... жою ... азайту үшін жұмыс бөлмелерін
изоляциялау керек, ол үшін оларды ғимараттын қала ... алыс ... Шу ... ... ... ... ... азаяды.
Тұрақты шу мінездемелері – дыбыстық давления дәрежесі ... ... 6.1 ... сызықтардағы дыбыс қысымының дәрежесі.
|дБ дәрежесі |63 |
| ... ... ... ... °C |22-24 |23-25 ... ... ... ... м/с |0.1 |0.1-0.2 ... ... ... % |40-60 |40-60 ... ... жоғарғы температурасы жоғарғы ылғалдылықпен ... ... ... ... әсер ... көрсетті.
Мұндай жағдайларда сенсомоторлық реакция уақыттары үлкейеді,
қозғалыстардың үйлестігі ... ... саны ... ... адамның психологиялық функцияларына теріс әсер
тигізеді. Сақталатын информацияның көлемі азаяды, елестету мүмкіншілігі ... ... және ... ... ... ... ынтасы
азаяды.
40 – 60% шекарасындағы салыстырмалы ылғалдылықтың адам күйіне ... Ал 99 – 100% ... ... ... ... ... механизм
толықтай өшіріледі және қайнап қызу басталады.
Жұмыс бөлмелерінде қажетті температураны және ылғалдылықты ... ... және ... ... ... қамтамасыз ететін және ауаны
шан ... ұлы ... ... жылыту және кондиционерлеу жүйелері
орнатылады.
Жүйені іске қосатын бөлмелерде микроклиматқа ... ... ... ... ... ... гигиеналық талаптарына сай келетін құрамын
ұстау үшін, және оны ұлы ... ... және ... ... ... ... ... көрсету жүйелеріне эргономикалық талаптар
Эргономикалық талаптар көру информацияның жарықтық, уақыттық ... ... ... ... ... ... бағасы жарық деңгейін нормалауды, көру информацияның
көрсеткіштерін эффективті өңдеу талаптарына жету үшін оның байқаушының көру
алаңына ... ... ... Оптималды деп жарықтың сондай
деңгейі есептелінеді, егер ол болғанда конкретті ... ... ... ... көру ... кіретін жарықтардың оптималды
диапазондарын орнатқандаадаптация деңгейіне жақын ... ... ... ету ... көру ... кіретін жарықтардың максималды қайта-қайта
өзгеруі 1:100-ден аспауы ... ... деп ... көзі және ... ... 20:1, ал бейненің ең жарық және ең қаранқы участкілері
арасындағы 40:1 ... ... ... ... ал ... ... ... жоғары
болған жағдайда, бейненің контрастілігі ... ... ... ... ... Информацияны бейнелеу жүесі және оның ... ... ... 3:1 қатынастан аспауы қажет.
Информацияны бейнелеу құралдары келесі техникалық талаптарға ... ... ... ... ... 100 Кд/м2 кем ... ... монитор үшін растра нүктенің минималды өлшемі 0.6 мм-
ден аспауы керек;
2. бейне контрастілігі 0.8 кем емес;
3. текстік режимдегі ... ... ... 72 Гц кем ... бір жолдағы растра нүктелерінің саны 640 кем емес;
5. экранның антибликтік қабықшасының болуы;
6. размер ... не ... 31 см по ... ... ... ... биіктігі 3.8 мм-ден кем емес;
8. оператор көзіненен экранға дейінгі арақашықтық 40-80 см;
9. монитор, оны 130-200 мм ... ... және ... және экранды 10-15( бұрышқа бұрауға мүмкіндік беретін,
астында бұралатын подставкамен ... ... ... ... ... ... комфортностты жұмысына оператордың жұмыс орынының
ұйымдастырылуы, информацияны бейнелеу құралдары, машинаны басқару ... ... ... ... ... ... ... және комфорты емес
сезімдерді тұғызбай, адам үшін максималды ыңғайлы болулары қажет және ... ... ... ... жағдайын қамтамасыз ететінің негізгісі- ол
оның жұмыс орнын ұйымдастыру болып табылады. Бұл ... ... ... жай ... ... әсері жоқ фактор көп уақыт бойы
әрекет жасаған жағдайда дискофортты ... ... ... ... ... ... қандай да бір ауыруға әкелуі мүмкін.
Оператордың монитор ... ... көп ... ... істеген кезде
оператордың көру аппаратының күшейуі белгіленеді және ... ... ... ... ... ... ... мойынның, белдің, қолдың ауыруына шағынудың пайда болуы.
Оператордың жұмыс орны стандарттар талаптарына және ... ... ... ... ... ... столының элементтерін ... ... ... адамның-оператордың жұмыс күйі;
11. барлық қажет қимылдарды қамтамасыз ететін, оператордың ... ... және ... ... ... көру және ... ... орынының шекарасының кеңістігінен артық қашықтықтағы
кеңістікті көру;
14. оператормен қолданылатын материалдарды және ... ... ... ... ... конструктивті және сыртқы бейнеленуі минималды шаршауға
жағдай жасайды. Жұмыс жиқазының конструкциясы ГОСТ талаптарына сай ... ... ... үшін ... ... ... және жұмыс істеп отырғанның
бойына қатысты жиналуын ... етуі ... ... ... дұрыс
ұйымдастырылуы кезінде ЭЕМ операторларының еңбек өңімділіктері 8-20%-ке
арттады. .
6.9 Жұмыс орынының эргономикалық талаптары
Жұмыс орынның конструкциясы және оның ... ... ... ... ... ... ... информацияны бейнелеу
құралдары) антропометриялық, ... және ... ... ... ... ... келуі қажет.
Жұмыс орынның берілген конструкциясы еңбек операцияларын мотрлық алаң
қызметінің шекаралық зонасында ... ... ... ... жету ... адамның орташа өлшемдері үшін горизонталды ... ... 4.1 ... ... ... ... жету зоналар және моторлық алаңдардың оптималды зоналар ... ... ... және «өте жиі» ... етіледі.
Информацияны бейнелеу құралдарының орналасуы, берілген жағдайда ... ... СниП ... [5]-ге ... ... 6.1. Адам ... моторлық алаңның жетуі
Сурет 6.2. Жету зонасы және моторлық алаңның оптималды зонасы
Көзге болатын жүктемені азайту ... ... ... ... оптималды орналастырылуы керек: дисплейдің жоғарғы шеті көз
деңгейінде болуы қажет, ал экранға ... ... ... 60 ... ... керек. Экранның жылпылдауының тазалығы fмер>70 Гц болуы қажет..
Лабораториялардағы жұмыс орындар терезелерге перпендикулярно орналасуы
керек, бұл экранның терезелерден, жасанды ... ... қызу ... яғни ... ... ... газозарядты лампаларды қолданудың
керегі жоқ), тура және тұңық болмауын алып ... үшін ... ... ... ... ... ... жобалау кезінде жасанды және табиғи жарықтандыру
мәселесі шешілуі керек. ... тек ... ... шешу үшін ... ... ... ... ол жұмыс істеп отырғанның психикалық және
физикалық ... ... ... ... бөлмелердің рационалды
жарықтандыруы келесілерге қатысты:
15. жарық көзін және жарықтандыру жүйесін дұрыс таңдау;
16. жұмыс беттердің жарықтандыруының қажетті ... ... ... ... ... ... тұрақты жарықтандыруды қамтамасыз ету;
19. жарық тасқынының уақыт мерзіміндегі тербелістерін шектеу немесе
болмауын жасау.
Жұмыс орнындағы жарықтандыру ... ... ... ... ... ... ... керек. Мысалы, ГОСТ ... ... ... ... ... ... 200 лк, ал құжаттармен
жұмыс істегенде – 400 лк. болуы керек.
Электронды-сәулелік трубканы пайдалану шартына сыртқы жарықтандыру және
байқау ... ... ... ... үш ... бөлінеді:
20. төмен (10 – 50 лк);
21. орташа (500 – 1000 ... ... ... 10000 ... жарықтандыру 30000 лк артық болса, онда оны азайту үшін шаралар
қолдану қажет.
Нұр шашудың зиянды ... ... үшін ... ... қолдануға болады, олардың интенсивтілігі азаяды. Сонымен қатар
Өлшеулер және ... ... ... ... Советімен ойланып тапқан,
MPR II спецификациясына жауап берін мониторларды қолдануға ұсыныс беріледі.
Спецификация тазалық сызықтар үшін ... ... ... ... 5 Гц – 2 кГц және 2 – 400 кГц. ... ... ... ... В/м, ал ... – 2.5 В/м ... ... сәйкес магниттік алаң күші 250
және 2.5 нТ болуы қажет.
7 Экономикалық бөлім
7.1 Оқу ... ... ... ... дамуының XXI ғасырында ақпарат негізгі қызметтік өнім болып
табылады. Сондықтан кітапханалық қызметтердің ... ... ... ... ... деп ойлаймын.
Әдетте кітапхана оқырмандары кітапханадан кез-келген ақпаратты ... ... ... негізгі қызметтерді орындау, яғни қорды
толықтыру, ақпараттық – библиографиялық және ... ... ... ... ... ... ақпаратты толық түрде жинау, сақтау
және қамтамасыз ету үшін, ол бір ... база ... ... ... ... ... ... жоғарылауы қажет.
Мәселенің мағынасы- ол студенттердің үлкен ... ... ... ... ... ... орны ... іс
қағаздарын сақтаудың пайдалы және қағазсыз жұмыс істеудің ыңғайлы құралы
болып табылады. ... ... ... әзірлеу үшін қандай да бір
универсалды ... ... ... ... ... ... жұмыс істеу үшін максималды икемденген, қосымша білімді
талап етпейтін, орындалтын файл ... ... жеке ... әзірлеу. Осы талаптарға сәйкес мына ... ... ... Экономикалық есептеулер жүргізу
7.2.1 Жобалауға кететін шығындар
Бұл шығындарға: жобалау, шараны енгізу, жабдықтар сатып алу, ... қою, ... ... ... жатады.
7.2.1.1 Әдебиеттік зерттеуді өткізуге кеткен шығындар
Мұнда мынадай мәселелер шешіледі: қажетті ... ... ... ... ... мамандығы, айлық жалақысы, кеткен уақыт бекітіледі. Бұл
мәлімет ... ... 7.1 ... ... ... |Айлық жалақы,|Зерттеуге кеткен ... ... ... ... ... ай | ... |50 |2 |100 ... ... |40 |2 |80 ... ... |40 |2 |80 ... |36 |2 |72 ... |36 |2 |72 ... |36 |2 |72 ... |476 ... ... ... өткізуге кеткен шығындар
Бұл кестеде зерттеуге қатысатын адамдар саны және ... ... ... уақыт, жалпы жалақысы келтірілген.
Кесте 7.2 Патенттік ... ... ... ... |Зерттеуге кеткен |Жалпы жалақы, |
| ... ... ай ... ... |50 |1 |50 ... ... |40 |1 |40 ... маман |40 |1 |40 ... |36 |1 |36 ... |36 |1 |36 ... |36 |1 |36 ... |238 ... Жолсапарға баруға кеткен шығындар
Мұнда келесідей мәселелер шешілді: қажетті жалақы, командировкаға
қанша адам барады, олардың мамандығы, айлық жалақысы, кеткен ... ... ... Бұл шығындар 7.3-кестеде келтірілген.
Кесте 7.3 Жолсапарға кеткен шығындар
|Мамандар ... |Жол ... ... ... жалақы,|
| |жалақы, |ақысы, ... ... ... |
| ... ... | ... ай | ... маман |40 |40 |35 |0,5 |90 ... |36 |40 |35 |0,5 |88 ... |36 |40 |35 |0,5 |88 ... |266 ... ... ... ... ... ... ... кеткен шығын
Кесте 7.4 Бағдарламаны жасауға кеткен шығындар
|Мамандар ... ... ... уақыт, ай |Жалпы жалақы, |
| ... | ... ... |50 |4 |200 ... ... |40 |4 |160 ... маман |40 |4 |160 ... |36 |4 |144 ... |36 |4 |144 ... |36 |4 |144 ... |822 ... ... ... үшін жалақы
мұндағы a, b, c, d - 3.1,3.2,3.3,3.4 – ... ... ... теңге.
Сонымен жазғы демалыс үшін 210 мың теңге бөлінеді.
7.2.1.6 Ауырғандарға ... ... ... ... ... ... және ... жалақысының қосындыларынан 1,5% алынады.
мың теңге.
7.2.1.7 Әлеуметтік салық
А÷Е сомасынан жеке зейнеткерлер қорына 10% ... ... ... ... салық есептелінеді. Яғни
Әс=
Әс=0.2[(636+318+296+1272+210)-0.1(636+318+296+1272+210)]=
=0.2[2732-273.2]=491.8 мың теңге.
7.2.1.8 Жобалау және жүйені жасау тобына арендаға үй алу үшін ... ... 6м2 таза ... ... керек. Коридорды, туалетті, қоймаларды
санасақ бір маманға шамамен 10м2 ... ... Сол ... біз ... ... ... 60м2 төрт бөлмелі пәтерді жалға аламыз. Айына
120000 теңге төленеді.
120000*7 ай=840000 теңге
7.2.1.9 Жабдықтарды ... алу және ... ... ... ... және ... БҚ ... қажетті қосалқы, арнайы мақсаттағы
техникалық және бағдарламалық құралдар дайындауға, оларды жобалауға,
дайындауға, дұрыстауға, ... және ... ... ... шығындар жатады. Сатып алынатын жабдықтар ... саны ... ... ... ... бағасы “Astek” фирмасының прайс парағынан алынған.
7.5-кесте Шығындар
|Жабдық ... ... мың тг. ... ... мың |
| | | |тг. ... |6 |83 |498 ... |3 |30 |90 ... |1 |50 |50 ... |4 |5 |20 ... |2 |15 |30 ... |1 |3 |12 ... |700 ... ... ... ... ... ... жылына: Аа=0.125*700=87.5 мың тг.
7.2.1.10 Материалдарға кеткен шығындар
Бұған ... ... ... ... қажетті магнитті
дерек тасушыға (МДТ), қатқыл ... мен ... да ... ... ... ... ... атауы, саны және бағасы (3.6)-
кестеде келтірілген. Бағалары “Abdi” фирмасының прайс парағынан алынған.
7.6-кесте Материалдарға ... ... ... ... ... мың тг. |Жалпы төлем, |
| | | | |мың тг. ... диск | |50 |0.23 |11.5 ... | |50 |0.09 |4.5 ... | |3 |2.5 |7.5 ... | |10 |0.5 |5 ... | |10 |6 |60 ... | |10 |0.05 |0.5 ... | |50 |0.2 |10 ... | |6 |6 |36 ... | |6 |2.5 |15 ... | |2 |0.3 |0.6 ... | |6 |0.8 |4.8 ... |155.4 ... ... үшін ... кВт * 0,004 мың.тг * 7ай= 14 мың.тг
7.2.1.12 Телефон үшін ... ... ... * 7 ай= 3 ... ... үшін ... мың.тг * 7ай= 21мың.тг
7.2.2 Бағдарламаны енгізу
7.2.2.1 Бағдарламаны енгізу жұмыстары
7.7-кесте Бағдарламаны енгізу жұмыстарына кеткен шығындар
|Маман ... ... ... ... ... |
| ... | | ... ... |46 |1 |50 |1.5 ... |46 |1 |50 |1.5 ... |3 ... ... түзету жұмыстары
7.8-кесте Бағдарламаны түзету жұмыстарына кеткен шығындар
|Маман ... ... ... ... жалақы,|
| ... | | ... ... ... |50 |1 |50 |1.7 ... |46 |1 |50 |1.5 ... |46 |1 |50 |1.5 ... |4.7 ... ... ... көбейтіп, этикеткаларын басып шығаруға
кеткен қаржы
0,04 мың.тг * 100 дана = 4 мың.тг
100 дискіге көшіру * 0,04 мың.тг = 4 ... ... ... ... бойынша кейбір салаларда жарнамалауға ... ... көп есе ... ... Біз ... 50 мың ... ... Барлық шығындар
Барлық шығын барлық баптардағы шығындардың қосындысына тең болады.
636+318+296+1272+210+41+491.8+840+700+155.4+14+3+21+3+4.7+4+4+50=
= 5063.9 мың.тг
7.2.6 Кірістер
7.2.6.1 Тура кірістер
Мұнда бағдарламаның қанша ... ... ... сатылатыны
есептелінген. Бағдарламаны заңды тұлғаларға сататын болсақ ... ал жеке ... ... болса арзан болады. Бағдарламаның құны – 15000
теңге. Сату бағаға қосылған құн салығы (Ққс) кіреді. Қосылған құн салығы ... тг + 15000* 14%= 15000 тг + 2100 тг = 17100 ... ... құны – 17.1 мың ... саны –350 ... ... * 350= 5985 ... Қосымша кірістер
Заңды тұлғаларға сатылатын бағдарламалар мен құралдар ... ... ... Сол ... құны – 5 мың ... Бұл құнда
кіріске косылады және бұғанда Ққс қосылады.
5 мың.тг +5000*14%= 5 мың.тг + 0,7=5.7 мың.тг
5.7 мың.тг * 350= 1995 ... ... + 1995 ... 7980 ... ... пайда
Жылғы жалпы пайда – бұл жылғы барлық кірістерден шығындар шегеруіне
тең сома. Жылғы жалпы пайдадан 30% ... ... ... ... ... төленуі тиіс. Қалғаны таза пайда болады.
Кіріс –7980 мың теңге.
Шығын – 5063.9 мың теңге
Пайда =кіріс – ... 7980 ... – 5063.9 ... = 2916.1 ... ... 2041.3 ... Тиімділік
Бағдарламадан түскен жылғы таза пайданы барлық шығынға бөлсек
тиімділік шығады: ... - ... ... ... ... ... 12% кем ... тиіс.
7.2.9 Шығынды өтеу мерзімі
Өтеу мерзімі тиімділікке кері шама.
жыл
7.2.10 Техника – ... ... ... ... ... ... ... |5060 ... ... ... ... саны |6 адам ... ... ... |7 ай ... бағасы (Қосымша құн салықсыз) |15 мың.тг ... ... саны |350 дана ... ... |5250 ... ... ... |2730 ... |
|Барлық кіріс |7980 ... ... ... |2916 ... |
|Таза пайда |2041 ... ... |40% ... өтем ... |2.5 жыл ... ... ... ... ... есептеу нәтижесінде 5063
мың. теңгені, сондай-ақ таза пайданы есептеу нәтижесінде 2041 мың.тг ... ... 2,5 ... ... ... құралдар жұмысының
тиімділігі:
- қорларды пайдалану төлемі;
- жарнама орнатудан түскен түсімдер (мысалы, басқа ЖОО);
- оқу төлемі.
Сондықтан, осы ... ... жоба ... ... ... өте тиімді болып, бағдарламалық қамтамасыз ету нарығында өзінің
барынша тұрақты орнын тауып және балама пакеттерге ... ... ... .
Қорытынды
Адамзат дамуының XXI ғасырында ақпарат негізгі қызметтік өнім болып
табылады. ... ... ... ... ... жасау негізгі мәселе деп ойлаймын.
Әдетте кітапхана оқырмандары кітапханадан кез-келген ... ... ... ... ... ... орындау, яғни қорды
толықтыру, ақпараттық – библиографиялық және ... ... ... түсуде. Кітапхана қорындағы ақпаратты толық түрде жинау, ... ... ету ... ол бір ... база ... құрылуы тиіс. Яғни
ақпаратты іздеу жылдамдығы жоғарылауы қажет.
Дипломдық жобаның актуалды тақырыбынің құрылымы ... ... ... ... ... ... ... беретін,
студенттер контингентінің жылжуын қадағалайтын, ... ... ... ... ... ... ... көшіретін жүйе өте маңызды болатындығын ... ... ол ... ... ... ... оқу ... автоматтандырылған жұмыс орны студенттердің іс ... ... және ... жұмыс істеудің ыңғайлы құралы болып
табылады. Жоғарыда ... ... ... үшін ... да ... ... құралдарын пайдалынбай, Windows-та жұмыс істейтін,
интерфейсі ыңғайлы ... ... үшін ... ... қосымша білімді
талап етпейтін, орындалтын файл ... ... жеке ... ... Осы ... сәйкес мына дипломдық жобаның
қажеттілігі туды.
Жасаған АЖО кітапханалық ... ... ... ... ... үшін қолданылады. Осындай АЖО-н жасау кітапхана қызметкерлерінің
жұмысын көп ... деп ... ... ... ... және жедел түрде алуға мүмкіндік береді.
• Мәліметтерді енгізуді оңайлатады.
• Отчеттарды тез алуға көмектеседі.
Оқырманға басылым туралы ақпаратты жылдам әрі дәл ... ... ... Дж. ... «Организация баз данных в вычислительных системах»,
Мир, Москва, 1990 г.
2. К. Дейт «Введение в системы управления базами данных», БИНОМ,
Москва, 1999 г.
3. В. М. ... А. С. ... и др. ... ... делу и библиографии», Издательство стандартов,
Москва, 1985 г.
4. В. М. ... и др. ... ... ... 1986 г.
5. М. А. Аппак «Автоматизированные рабочие места на основе ... и ... ... 1989 г.
6. В. Л. Бройдо, В. С. Крылова «Научные основы организации управления
и построения АСУ», Высшая ... ... 1990 ... А. Ф. ... «Персональные ЭВМ в организационном управлении»,
Наука, Москва, 1988 г.
8. «Библиотекарь», Журнал № 1-10 2007 г.
9. «Библиотекарь», Журнал № 6-12 2006 ... ... ... № 1-12 2005 ... ... ... № 1-3 2000 ... ГОСТ 12.2.032-78. ССБТ (Система ... ... ... ... при ... ... ... Общие эргономические требования.
13. СанПиН для работников вычислительных центров от 22.05.95 ... ГОСТ 2239-79. ... ... ... ... ... ... нормы и правила (СанПиН) 2.2.2/2.4.1340-03. Гигиенические
требования к персональным электронно-вычислительным машинам и организация
работы.
16. Федеральные законы: «Об акционерных ...... ... 29 ... 2004 г.); «Об ... с ограниченной ответственностью» (в
последней редакции от 29 декабря 2004 г.) – М.: Книга ... 2005. – ... Все ... по ... ... – М.: ЗАО ... Дом
«Главбух». – 2002. – 160 с. – («Бухгалтерская ... План ... ... ... и ... по его применению: С
изменениями и ... ... ... Минфина РФ от 07.05.2003
№ 38Н. – Новосибирск: Мысль, 2003. – 128 с.
19. Бухгалтерский учет в ... ... / М. С. ... – М.: Финансы
и статистика, 1991. – 176 ... ... ... учета на современном малом и ... ... ... / А. Ю. Гридасов, О. С. Рябых, С. А. ... ... Г. ... – Новосибирск: НГТУ, 2002. – 134 с: ил.
21. Комплексная автоматизация бухгалтерского учета в промышленности / ... ... – М.: ... и ... 1987. – 143 ... Питеркин С.В., Оладов Н.А., Исаев Д.В. ... ... для ... ... ... – М.: ... ... 2002. – 368 с.
23. Сайт фирмы «1С» по платформе «1С:Предприятие 8.0»: http://v8.1c.ru/
24. Киселев А.Г. Интегрированная ... ... для ... (ERP): учебное пособие. – Новосибирск – 2004. – 219 с.
25. Форум сайта ITLand (ERP, MRP II, FRM, CRM, HRM & ... ... ... в ... в ... «1С: ... 8.0». Основные
объекты: Методические материалы для слушателя сертифицированного курса
(редакция 2). – М.: Фирма «1С» – 2004. – 93 ... ... ... ... ... ... УстКниги()
Если Число(СрокВозврата)=0 Тогда
СрокВозврата = ДатаДок + Константа.КолвоДнейДляВыдачи;
КонецЕсли;
Если Произведение.Выбран()=0 Тогда
Произведение = Книга.Владелец;
КонецЕсли;
КонецПроцедуры
Процедура ПриЗаписи()
Если ... ... ... ... ... ... = Перечисление.ДаНет.Да
Тогда
Предупреждение("Этот читатель не может взять книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если КоличествоСтрок()=0 Тогда
Предупреждение("Не указано ни одной книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Произведение.Выбран()=0 ... ... " + ... + " ... ... ... Книга.Выбран()=0 Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " ... ... ... ... ... ... строке " + Строка(НомерСтроки) + " книга
не является Свободной!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Число(СрокВозврата)=0 Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " ... срок ... ... на ... книг у ... = ... = создатьОбъект("Справочник.Книги");
СпрКниги.ВыбратьЭлементыПоРеквизиту("Читатель",Читатель,0,0);
Пока СпрКниги.ПолучитьЭлемент()=1 Цикл
КолвоКнигНаРуках = КолвоКнигНаРуках + 1;
КонецЦикла;
Если ... + ... ... ... ... ... слишком много книг на
руках!");
СтатусВозврата(0); Возврат;
КонецЕсли;
КонецПроцедуры
Кітаптар ... ... ... ... ... ... = создатьОбъект("Справочник.Книги");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
СпрКниги.НайтиЭлемент(Книга);
СпрКниги.Статус = Перечисление.СтатусКниги.Выдана;
СпрКниги.Читатель = Читатель;
СпрКниги.ДатаВыдачи = ДатаДок;
СпрКниги.СрокВозврата = СрокВозврата;
СпрКниги.Записать();
КонецЦикла;
КонецПроцедуры
Кітаптың уақытын ... ... ... ... ... ПриЗаписи()
Если Читатель.Выбран()=0 Тогда
Предупреждение("Не указан читатель!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Читатель.Блокирован.Получить(ДатаДок) = Перечисление.ДаНет.Да
Тогда
Предупреждение("Этот читатель не может продлить ... ... ... ... ... ни ... книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
УказанХотяБыОдинНовыйСрокВозврата = 0;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если Произведение.Выбран()=0 Тогда
Предупреждение("В строке " + ... + " ... ... ... ... ... строке " + Строка(НомерСтроки) + " ... ... ... ... ... Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " книга
не ... ... ... ... ... = ... УказанХотяБыОдинНовыйСрокВозврата = 0 Тогда
Предупреждение("Не продлена ни одна книга! Должен быть указан
хотя бы один ... срок ... ... ... = ... ... ... = СпрКниги.ТекущийЭлемент();
Произведение = СпрКниги.Владелец;
СрокВозврата = СпрКниги.СрокВозврата;
КонецЦикла;
КонецПроцедуры
Процедура ПриВводеСтроки()
СтатусВозврата(0);
КонецПроцедуры
Процедура ПриУдаленииСтроки()
СтатусВозврата(0);
КонецПроцедуры
Кітаптар уақытын ұзарту құжатын өткізу модулі:
// ********************
//
Процедура ОбработкаПроведения()
СпрКниги = ... ... ... ... Тогда
СпрКниги.НайтиЭлемент(Книга);
СпрКниги.СрокВозврата = НовыйСрокВозврата;
СпрКниги.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Кітапты қайтару құжатының формасының программалық модулі:
Процедура УстКниги()
Если Произведение.Выбран()=0 Тогда
Произведение = ... ... ... ... указан читатель!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если КоличествоСтрок()=0 Тогда
Предупреждение("Не указано ни одной книги!");
СтатусВозврата(0); Возврат;
КонецЕсли;
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
Если ... ... ... " + ... + " не
указано произведение!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Книга.Выбран()=0 ... ... " + ... + " ... книга!");
СтатусВозврата(0); Возврат;
КонецЕсли;
Если Книга.Статус Перечисление.СтатусКниги.Выдана Тогда
Предупреждение("В строке " + Строка(НомерСтроки) + " книга
не является Выданной!");
СтатусВозврата(0); ... ... ... ... ... ... ... ОбработкаПроведения()
СпрКниги = создатьОбъект("Справочник.Книги");
СпрЧитатели = СоздатьОбъект("Справочник.Читатели");
ВыбратьСтроки();
Пока ПолучитьСтроку()=1 Цикл
СпрКниги.НайтиЭлемент(Книга);
Если СпрКниги.СрокВозврата < ДатаДок Тогда
СпрЧитатели.НайтиЭлемент(Читатель);
СпрЧитатели.КоличествоПредупреждений ... + ... ... ... ... ... ... +
Константа.КолвоДнейБлокировки);
КонецЕсли;
КонецЕсли;
СпрКниги.Статус = ... = ... = ... = ... ... жабдықтарды құруға
арналған құралдар
Жүйенiң қызметiн қамтамасыз ететiн есептеу жүйесiнiң ресурстарын басқару
Функционалды ПҚ
Жалпы ... ... және ... ... ... жабдықтар
Автоматтандырылған жұмыс орны
Форма k
Запрос Nψ
Запрос N1
Запрос 1η
Запрос 32
Запрос 31
Запрос 1k
Запрос 12
Запрос 11
Пользователь
Форма γ
Форма 3
Форма 2
Форма 1
Таблица k
Таблица μ
Таблица 3
Таблица 2
Таблица ... ... ... ... ... ... ... 12
Запрос 11
Форма N
Форма 3
Форма 2
Форма 1
Қолданушы
Жұмысты аяқтау?
Ия
Баспа
Соңы
Баспаға шығару
Ақпаратты көрсету
Форма жазбаларын толтыру
Шығыстық форманы таңдау
Хабар-а беру
Сұраудың орындаушы бөлiктерiне ақпаратты беру
Ақпарат ... ... ... ... және ... ... мәлiметтерiн беру
Мәлiметтер дұрыс па?
Мәлiметтердi анализдеу
Мәлiметтердi енгiзу
Ия
Ия
Ия
Жоқ
Жоқ
Жоқ
Жоққққ
Қызметтiк ақпаратты енгiзуге арналған модуль
Түзету модулi
Шығару ... ... ... ... ... бар ма?
Соңы
Қатенi өңдеу және хабарлама беру
Таңдалған функцияны орындау
Меню пунктiн таңдау
Кiруге рұқсат бар ма?
Идентификациялау және аутентификациялау модулiн iске ... орын бөлу және ... ...

Пән: Автоматтандыру, Техника
Жұмыс түрі: Материал
Көлемі: 52 бет
Бұл жұмыстың бағасы: 300 теңге









Ұқсас жұмыстар
Тақырыб Бет саны
Жобалаудың жалпы сұрақтары6 бет
"Патенттік құжаттар"3 бет
1.Түркітануға байланысты алғашқы зерттеулер. 2.Орыс ғалымдарының түркітануға байланысты зерттеулері. 3.ХХ ғасыр басындағы түркітану тарихы5 бет
HTML тілінде «Мұхтар Шаханов» атты сайт жасау15 бет
Windows server атты операциялық жүйелер тобы17 бет
«9-қабатты офистік ғймарат» тақырыбына арналған дипломдық жобаның есептеу-конструкциялық бөлімі9 бет
«Испания журналистикасы» атты ғылыми-зерттеу жұмысына тезис11 бет
«Кабельдің бірінші реттік параметрлерін өлшеу» атты зертханалық жұмыс3 бет
«Камшат» атты қыздар әшекей бұйымдарының жиынтығы25 бет
«Цитрамон П» өндірісінің автоматты басқару жүйесі10 бет


Исходниктер
Пәндер
Көмек / Помощь
Арайлым
Біз міндетті түрде жауап береміз!
Мы обязательно ответим!
Жіберу / Отправить


Зарабатывайте вместе с нами

Рахмет!
Хабарлама жіберілді. / Сообщение отправлено.

Сіз үшін аптасына 5 күн жұмыс істейміз.
Жұмыс уақыты 09:00 - 18:00

Мы работаем для Вас 5 дней в неделю.
Время работы 09:00 - 18:00

Email: info@stud.kz

Phone: 777 614 50 20
Жабу / Закрыть

Көмек / Помощь